Openwrt 21.02.1 vsftpd not working

First I want to say, I have tried openwrt on my netgear wndr3800 router and my pc, the problem is same.
what I did:
download ​for my pc and install it.

download for my wndr3800 router and install it.

after the fresh installation,
opkg update
opkg install vsftpd
issue "service" to list all service status.
vsftpd is on status "stopped".
/etc/init.d/vsftpd start
/etc/init.d/vsftpd restart
I try all, but vsftpd is still stopped.
then on other pc, issue "ftp", an error "500 oops: child died".
this problem is all on wndr3800 and my pc with openwrt.

then I tried openwrt 20.02.0 version, same problem.

then I tried openwrt 19.07.8, after issue those same commands, vsftpd work fine.

what I have tried is to install openwrt, issue same commands, I do not change vsftpd.conf.
So can we say, on openwrt 21.02.x version, there is a bug about vsftpd?

where seem to be some config differences between 21 and 19, and 21 doesn't appear to work out of the box.

see if this helps Vsftpd issue with connection in OpenWrt 21.02 - #19 by kisond

1 Like


Then vsftpd works.
Thank you very much

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.