OpenWrt 21.02.1 - Fritzbox 3370 - HW Subrevision 3 - Problems flashing

Hi there,

i recently got a cheap Fritzbox 3370 with following data:

HWRevision 175
HWSubRevision 3
urlader-version 2186
NAND device: Manufacturer ID: 0x20, Chip ID: 0xdc (ST Micro NAND04GW3B2DN6), 512MiB, page size: 2048, OOB size: 64

According to all HW-Subrevision >= 2 are supported.

I tried to flash latest OpenWRT according to with following output:

Connected to
220 ADAM2 FTP Server ready
ftp> quote USER adam2
331 Password required for adam2
ftp> quote PASS adam2
230 User adam2 successfully logged in
ftp> bin
200 Type set to BINARY
ftp> deb
Debugging on (debug=1).
ftp> pas
Passive mode on.
ftp> quote SETENV linux_fs_start 0
---> SETENV linux_fs_start 0
200 SETENV command successful
ftp> quote MEDIA FLSH
200 Media set to MEDIA_FLASH
ftp> put openwrt-21.02.1-lantiq-xrx200-avm_fritz3370-rev2-hynix-initramfs-kernel.bin mtd1
local: openwrt-21.02.1-lantiq-xrx200-avm_fritz3370-rev2-hynix-initramfs-kernel.bin remote: mtd1
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (192,168,178,1,12,3)
---> STOR mtd1
150 Opening BINARY data connection
426 Data connection closed
5630234 bytes sent in 3.46 secs (1.5526 MB/s)
ftp> put openwrt-21.02.1-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-filesystem.bin mtd0
local: openwrt-21.02.1-lantiq-xrx200-avm_fritz3370-rev2-hynix-squashfs-eva-filesystem.bin remote: mtd0
ftp: setsockopt (ignored): Permission denied
---> PASV
227 Entering Passive Mode (192,168,178,1,12,12)
---> STOR mtd0
150 Opening BINARY data connection
226 Transfer complete
5242880 bytes sent in 3.48 secs (1.4356 MB/s)
ftp> quote REBOOT
221 Thank you for using the FTP service on ADAM2
ftp> quit
---> QUIT
221 Goodbye.

Unfortunately, the Box wont boot after reboot, the INFO-Led is blinking red. FTP-Server is still reachable, i can repeat the flashing-procedure with same result.

Did i miss something?

Kind regards and enjoy the holidays.

Edit 1: Pasted codelines of another (full) attempt, in the initially pasted lines i forgot " quote SETENV linux_fs_start 0".

Yes, you omitted one command. As per the instructions the active partition must be set to 0:
ftp> quote SETENV linux_fs_start 0

Ok, my fault, i posted the one of my attempts where i forgot to use thise command. I edited the initial post and added the output of the attempt i did before.

...initramfs-kernel.bin is the wrong image (part), initramfs is generally used to run OpenWrt in memory for testing and debugging, it is not intended for flashing.

You need to use ...squashfs-eva-kernel.bin for mtd1.

Sorry I did not catch this earlier.

Oh boy. Checked the lines again and again and using the wrong image for flashing again and again.

Thank you and nice holidays.

EDIT: Maybe a mod could change topic to "OpenWrt 21.02.1 - Fritzbox 3370 - HW Subrevision 3 - Problems flashing" - to avoid impression of non-working software. Thanks.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.