OpenWrt 21.02.0 third release candidate

i don't know much about releasing contributions, but i think is the best way just make topic and show what you can do.

1 Like

OpenWRT Contributions: https://openwrt.org/faq/how_can_i_help_or_contribute
LuCI Contributions specifically: https://github.com/openwrt/luci/blob/master/CONTRIBUTING.md

3 Likes

I'm seeing two issues on 21.02rc3 with multiple instances of dnsmasq.

  1. Problems stopping/restarting instances with error message Cannot add object to UBus: Invalid argument. I believe this one is addressed by commit ba5bd8e5 (dnsmasq: distinct Ubus names for multiple instances) in master but hasn't been ported to the 21.02 branch.
  2. DHCP leases are being shown for dnsmasq instances that are disabled (I alternate between two dnsmasq instances but use the same DHCP settings i.e. the same leasefile). Each lease is being displayed twice as the same leasefile is being parsed twice (possibly two issues - first, don't parse the lease file on disabled instances - second, parse only each file once? )

Otherwise, doing great on the 21.02 branch! Thanks all for the great work.

Is everything on https://openwrt.org/docs/guide-developer/releases/goals/21.02 able to be closed off or should we expect a few more RCs as things are finished?

ML thread

We need RC4 version soon, there is so many things fixed. Nobody know what problems still have.
DHCP static leases not working very well. Many times some static leases trigger some mystery counter (99d?) TP-link c7 V2

1 Like

There is no rush on that. Just update your packages or install the latest 21.02-snapshot, there was one done on 7/14.

Hi
I noticed one problem, maybe it is fixable or later must reboot device if necessary

  • TP-Link c7 v2 and latest snapshot.

Procedure: i have installed working https://openwrt.org/docs/guide-user/network/wan/smartphone.usb.tethering

  1. I have working wired WAN internet and it´s working well.
  2. I connect cellphone to usb and set usb tearing on from phone. It´s starting work via phone internet.
    I remove wired WAN and all still good.
  3. Remove phone USB and connect Wired WAN back to router.
    Internet connection not goes up until i reboot router, not even wired WAN show TX and RX transmission.

I report a bug. After testing, openwrt 21.02-rc3 version: the interface protocol "PPPoE" severely limits the network speed, or "the network speed is seriously not up to the speed provided by the service provider“

Bugs are tracked at https://bugs.openwrt.org. While discussion here is useful and brings exposure, it can't replace proper reporting and tracking (which doesn't work in the forum at all).

This statement is rather ambiguous.
Are you reporting a performance regression with PPPoE enabled between 19.07.x and 21.02~ (or previous, vanilla, OpenWrt versions - not some vendor firmware/ SDK relying on hardware offloading) XOR are you noticing a performance impact of using PPPoE? The former could be a bug (but would require further debugging, depending on how large the delta relative to previous OpenWrt versions really is - and after ruling out that newer pppd versions don't default to different protocol interfaces), the later is a matter of fact and unchangeable (apart from throwing faster hardware at it). PPPoE does significantly increase the overhead of your connection, with a noteworthy impact on performance.

+1 for sort-able tables. I wanted those for a while too. I want to see all the connections made by one device. It would be great if you contribute.

1 Like

@gaoping is wrong, i've use PPPoE whole time, all RC versions, from 18.06 no issues, X86 system, can provide any proofs or reports. There is NO regression.

Hello.

I am very new to OpenWRT and I am not sure this is the right place to ask the following...

So I just bought a DFRobot Raspberry Pi Compute Module 4 IoT Router Carrier Board Mini and a Raspberry CM4 w/2GB RAM. I already installed the image supplied by DFRobot on a microSD card. It works perfectly so far. However I wanted to install the package openvpn-openssl and it says " The installed version of package kernel is not compatible, require 5.4.132-1-deb45357… while 5.4.108-1-79565365… is installed.". The exactly the same error happened when I tried to install kmod-usb-net package for my 4G LTE modem. I assume the kernel in my precompiled image is too old (which is OpenWrt 21.02-SNAPSHOT, r15935-2db7fe792e). But I also seen in the Release Notes of the latest RC, that the kernel version is 5.4.124, which is still below what is required for me. Does this mean that even when 21.02 will be released the kernel version will be 5.4.124, so I will have no chance to use OpenVPN or my 4G modem as backup on this hardware? Is there any way or possibility to manually bump-up the KERNEL without bricking the actual install?

Thank you in advance,

Balazs

You won't ever be able to install any packages for a snapshot a day or two after the snapshot was created as it will be wiped and replaces by the next snapshot

Your options are

  1. find out which snapshot was used and download and prepare a new SD cars with latest snapshot and promptly install any packages you need.

  2. use imagebuilder to build your own images.

  3. wait/check for a release image to be available for your device

I think this is not that simple, as they modified the official OpenWRT RC snapshot by including some drivers supporting their board (mainly for the additional NIC on the board). Unfortunately I am not that big Linux guru to recompile a snapshot by including the required drivers, etc.. DFRobot told me on their website that 21.02 will officially support their product once it will be finally released, so I assume I just need to wait a bit longer and fingers crossed that the final version of 21.02 will contain the right version of the KERNEL required for my packages.

Thanks,
B.

In that case you need to contact the manufacturer.

Yes it is.

You talk about security updates for the Kernel, 108 to 132! Not the kernel version.

132 was installed in 21.02-snapshot 40hours ago. 128 was installed at 2021-06-26.
108 was installed at 2021-03-27. That is even before rc1 was released!
We run rc3 or newer for 21.02 nowadays so the fault isn’t OpenWRT. It is the manufacturer that has made that firmware to begin with.

Thank you for the clarification. Since they are claiming that that official version of 21.02 will support this board with CM4, I still think the only thing I can do is to wait. Or... I should try RC3 on my router as it should already included all the needed drivers, because it is so close to the production version. Generally it uses the built in ETH of the CM4 and an additional RTL8111 hooked up to the PCIe of the CM4 so it doesn't seem a very exotic solution and hardware components. Which version of the RC3 should I try to install?

CM4 IoT Router Board Mini for Raspberry Pi Compute Module 4 Wiki - DFRobot

Should this be the right place for CM4?
Index of /snapshots/targets/bcm27xx/bcm2711/ (openwrt.org)

You can create a custom image using https://chef.libremesh.org/ with all the packages you want included in the list.

I suggest sticking to 21.02 RC releases rather than 21.02-SNAPSHOT or Git "master" branch SNAPSHOT.

Based on How to install RTL8111 network card driver on 19.04 - #2 by slh, kmod-r8169 is the kernel module for RTL8111 PCIE Adapter.

1 Like

Hello,

I was able to flash the right factory image (ext4). The thing is that openwrt works out of the box with the RTL8111 controller DFRobot was added to the board, and cannot recognize the CM4's built-in ethernet controller. This is the output of the lspci command:

root@OpenWrt:~# lspci
00:00.0 PCI bridge: Broadcom Inc. and subsidiaries BCM2711 PCIe Bridge (rev 20)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

This is kind of strange as the SOC for CM4 is exactly the same as for RPI4. So I would expect that the built-in controller to work out of the box and not the RTL8111.

Should I install any kmod package in order to get it working?