OpenWrt 21.02.0 third release candidate

Yes, such manual optimization (pinning certain IRQ activity to specific cores) can be very useful. But this is not what irqbalance does (it tries to distribute IRQs over all cores, at least by default). And that's why I'm saying it depends on the use case and hardware whether irqbalance is actually beneficial.


I noticed with Sheduled tasks. We have GUI to change settings, but need do extra work with SSH. "/etc/init.d/cron restart" if we need change something.
Is possible do this every time when press save button in shedule?


As it say in the GUI, you only need the restart after the first cron job definition.
This is on system level mostly because the actual config file doesn’t even exist in etc/cronjobs until, you do the first job.
So it haven't loaded anything before this.

It has been a while since I got my tasks up-n-running using LuCi but as far as I can remember the biggest problem was the task code itself and that it was some kind of fault/mixup in the instruction for the placements of the time numbers.
When looked in the log most of the time the cronjobs was activated but they didn’t do anything because the job-code didn’t work.

When that was sorted out it worked better.

But if you wrote the lines directly in the config file I was forced to restart the cronjob.

But the cron job function isn’t really the smartest program in the box if I put it gently.

Have you tried to call a script instead using this “complicated” code?
The only thing I have managed to get working directly in cronjob is to restart adblock and banIP to make them update the definitions every night.

Maybe this year.

You could read the release goals:

I think i solved my sheduled problem, i change timezone.
System use different time than system local time.
cron use openwrt system local time added timezone. I think my system use time, what i set in local time. I started investigate why system log times was different compared for my time.

with wrong timezone

Already the cases in precedent releases !
Never find why but logs time looks to be UTC for most, and some are correctly GMT.

1 Like

Yes, but in openwr it mess cron schedule.
And everytime, must do cron restart, if change sheduled tasks times.

I hope some fixing this, like sheduled tasks save button restart cron automically. System time show correct system time. Then this works much easier.

May I have to open an issue on this ?

root@ultra:~# fw_printenv 
Warning: Bad CRC, using default environment
bootcmd=bootp; setenv bootargs root=/dev/nfs nfsroot=${serverip}:${rootpath} ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:${hostname}::off; bootm
root@ultra:~# cat /proc/mtd 
dev:    size   erasesize  name
mtd0: 003e0000 00010000 "firmware"
mtd1: 00010000 00010000 "hw-info"
mtd2: 00010000 00010000 "u-boot-env"
root@ultra:~# cat /etc/fw_env.config 
/dev/mtd2 0x0 0x10000 0x10000 1
root@ultra:~# cat /etc/board.json 
	"model": {
		"id": "globalscale,espressobin-ultra",
		"name": "Globalscale Marvell ESPRESSOBin Ultra Board"
	"network": {
		"lan": {
			"ports": [
			"protocol": "static"
		"wan": {
			"device": "wan",
			"protocol": "dhcp"

That does not necessarily need to be a "real" failure. It can also mean that the U-Boot environment simply has never been written before and therefore it will just rely on the compiled-in default.

Thanks, but not the case here...

I just reboot to u-boot and save env... boot again in OpenWrt 21.02-RC3 and still get the same CRC checksum error message on fw_printenv !
The problem in that case is that fw_saveenv will broke the u-boot env...

while it's possible... this is usually the case when a user has performed some non typical actions...

suggest you create a new thread detailing exactly ALL the steps that were undertaken prior to the env being written to defaults...

(you've included about 10% of the picture so far)

Is this a known issue with this device and the latest builds (daily and / 21.02 rc3) that wifi 2.4 ghz doesn't show up, after rebooting the device multiple times it comes back

I think it happen first time.
I think you can try pull it up with Putty
/sbin/wifi up; wifi
or with separate commands
uci set wireless.radio0.disabled=0; uci commit wireless; wifi reload

Please check you not have any scheduled tasks and be sure it with refreshing /etc/init.d/cron restart
I was many problems couple messages up, because schedule was running uncontrolled time and state.
Added issues

With luci-proto-wireguard installed, I don't see Wireguard listed as a protocol in the drop down menu for protocol in the luci network interface setup menu on my ER-X. Perhaps luci-proto-wireguard doesn't work with the luci changes for DSA yet?

EDIT: Solved below - I just needed to reboot the router. Apologies for the noise.

I think luci-proto-wireguard not development much anymore.

OPENWRT 21.02 come WITH kernel 5.4 and wireguard come migrate in kernel 5.10.
What is support state in kernel 5.4
"Linux 5.4, build WireGuard from backports."
Maybe need install something like
opkg update
opkg install wireguard

I have installed wireguard-tools, kmod-wireguard, luci-app-wireguard and luci-proto-wireguard. Wireguard is not listed as a protocol in the drop down menu for protocol in the luci network interface setup menu on my ER-X.

With current snapshot on my EA8500 (also on kernel 5.4), the drop down for the Wireguard protocol exists in the interface menu, so it looks like it is still supported. Just not on the ER-X, which has been migrated to DSA.

EDIT: Solved below. I just needed to reboot the router. Sorry for the noise.

Have you reset the Luci interface ?

I have it on MVEBU 21.02-RC3...

Not sure what is meant by reset the interface, but it's not an option for me even when I create a new interface. I can't grab a screen capture with the pull down menu showing (the pull down menu disappears when I click on the screen capture app), but it's definitely not an option for me when I make a new interface.

I clicked the "Reset" button on the bottom of the Network>Interfaces menu in Luci. Other then a brief screen flicker in the window, it did not appear to do anything.

No, I do not mean the Network interface, but the Luci WEBUI !
Remove cache...
Or logout and login again...
Or reboot...