OpenWrt 21.02.0 second release candidate

My D-Link DIR-860L B1 act a similar role as AP, downgraded from the snapshots to 21.02.0 rc2 yesterday.

I like the new luci settings which helped me with most of the configurations: port 1 connected to a switch which is behind the main router, while port 2-4 formed another independent switch, and the wireless clients are routed through port 1 as gateway. Part of my configuration is as follow:

config device
        option name 'br-lan'
        option type 'bridge'
        option macaddr '54:xx:xx:xx:xx:90'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'
        option gateway '192.168.1.2'

config device
        option name 'lan1'

config interface 'lan_gateway'
        option proto 'dhcp'
        option device 'lan1'

I migrated my archer c7 config manually.

first, a switch section per vlan

second, a device section per bridge

third, an interface per wifi .

so it's built like this: switch -- bridge device -- interface -- wifi attached

Hi. I upgraded my raspberry pi 4. I am using it as a remote vpn client. However, the wireguard protocol now asks me to select a device. Am I supposed to choose the WAN or the alias interface wireguard?

Cheers

Could you share your configuration as well, please? Then I'll give this another try on the weekend. I wanted to set up different VLANs for different virtual APs (or SSIDs) anyway, it just hasn't been at the top of my list yet.

Does this mean that it is now possible to migrate all the 19.07.07 configuration of a TP-Link Archer C2600?

I can't find any code handling igmp_v3 option at all.

igmp_snooping for example should go to the config device UCI section.

For a reference: it seems to be related to @anon2180415's custom network interfaces, see Network migration 21.02.0-rc2 - #8 by anon2180415

1 Like

Can you provide your working and broken /etc/config/network (before & after migration)?

1 Like

@siltentcreek My config before and after manual migration can be seen at: Network migration 21.02.0-rc2 - #11 by pgn-1111

1 Like

@silentcreek: it seems like you hit the same problem Hauke reported in the
Bridge migration breaks network configuration
that problem was fixed in the:

Above fix is part of the 21.02-rc2 release.

It seems you installed some snapshot with outdated LuCI instead of actual rc2. Can you verify that?

Your interface should have device set to br-lan (not eth1.1)

@rmilecki Does it somehow matter that I've used ImageBuilder on 21.02.0-rc2 or is this expected to have exactly the same packages like the official image?

LuCI should not require that, it's probably a bug, I've to verify it it was fixed (after rc2 release) by @jow's changes.

1 Like

LuCI migration code handles only switching from:

  • Old bridges syntax
  • Using deprecated ifname option in config interface sections

It does not migrate swconfig setups to DSA setups.

2 Likes

I don't think it needs option list for wifi interface

But in the wireless config file
/etc/config/wireless it needs

option network 'lan'

For each wifi interface

1 Like

In short no... it makes little difference...

Packages are dependent on what options you provide when using the imagebuilder...

these LUCI modifications/migrations occur after the boot process and are user triggered... so if you are using an imagebuilder image with sysupgrade then there is little difference

the migration above is targeted at sysupgraded network configs...

verbage

Certain ./files can interact with initial config generation or (user selected) package uci-default mechanics... changes here are not directly related to the migration process and would need to be examined on a package by package basis... Otherwise don't remove critical/typical system packages...

1 Like

I did not use a snapshot, but like @anon2180415 I used the official ImageBuilder for 21.02.0-rc2 (and I waited until the release showed up on the front page). And this seems to be the culprit. Because my image has the package version git-21.147.37148-a86e770 of luci-mod-network which does not include your fix. There is however a newer version of that package available via opkg. So, I will try that again later. Looking at the openwrt-21.02.0-rc2-ath79-generic.manifest file, I can also see that the official image comes with a newer version of luci-mod-network, namely git-21.149.58794-09329fe which includes your fix.

In any case, I'm a bit puzzled now because I always assumed the image builder would generate images with the same packages as the official images (or at least not older than that). But that doesn't seem to be true, apparently. :face_with_raised_eyebrow:

2 Likes

As I just wrote above, it does apparently make a difference. Using the official image builder for rc2, I ended up with a luci-mod-network package that is older than the one included in the official image.

2 Likes

That is and was the case in my setup. I haven't changed the wireless configuration during or after upgrading to rc2. The only changes were in /etc/config/network. But as rmilecki pointed out. The problem seems to be that my bridge interface only includes eth1.1 and not br-lan after the conversion due to an outdated luci-mod-network. I will test later again with the new package version.

1 Like

please provide hashes versions and date/time used so we can validate/investigate...

edit: probably best to fork a new thread and link it here as this is relevant broadly and may get text heavy...

1 Like

Hashes/versions/dates of what exactly?
I downloaded the openwrt-imagebuilder-21.02.0-rc2-ath79-generic.Linux-x86_64.tar.xz and the sha256sum matches the one currently listed in the download folder on openwrt.org: 0ea42f0fc00e891a21f5eb310b486c953c1b4eec259e489237adf55385b39379
I already mentioned that version of luci-mod-network that was packaged by the image builder was git-21.147.37148-a86e770 while the official images seem to have git-21.149.58794-09329fe. I built the image between 1am and 2am on June 1st (CEST).

I did not keep the build directory, though, so I can't check which revisions/heads of the package feeds were downloaded or that sort of thing.

Could this have anything to do with the fact that by default the image builder won't even include luci unless you add it to the PACKAGES variable?

1 Like

Wow, thanks for debugging & sharing that info!

Image Builder downloads packages from online repository, in your ath79 case that is:
https://downloads.openwrt.org/releases/21.02.0-rc2/packages/mips_24kc/luci/

Above repository contains luci-mod-network_git-21.151.71533-b860704_all.ipk but it seems it was uploaded just recently on the Jun 2 00:30:58 2021! My guess is that at your image building time above repository contained outdated package and that has poisoned your device image!