OpenWrt 21.02.0-rc4-Can't access Software list, can't resolve domain

Wifi router, work as access point: D-link DIR-2660
OpenWrt 21.02.0-rc4
Router: PfSense 2.5.2, handling firewall, dhcp, dns

Network diagram:

Before getting this D-link router, I have 3 APs (Freshtomato, OpenWrt 19.07) setup without problem. I can get software list, can diagnose by ping, traceroute, and nslookup functions on OpenWrt fine.

But with D-link on OpenWrt 21.02.0-rc4, everything works fine (devices connected to all lan ports, all wifi ssids/main and vlan, can access internet without problem), but the D-link AP itself can't resolve any domain name. Ping, traceroute, and nslookup on Luci GUI, can't find the sites; thus update Software list can download software list due to not being able to resolve downloads.openwrt.org site. It can ping public IP addresses, though.

I do not change anything on my pfSense, which setups work with other APs I have. All other APs I tested also plugged to the same ethernet port of PfSense box. Same fixed network IP (192.168.8.254).....

I really can't solve this problem. Need some clue as to what are the possible cause.

Thanks.

Does the D-Link have a static IP set? if that's the case, you manually have to provide the DNSes.

2 Likes

Like frollic said, you need to provide the DNS address and the gateway for the router's config, as it does not get it via DHCP like the client PCs.

1 Like

This is my current setup:

you left out the best part :wink:
although the Luci interface might differ between 19.07 and 21.02-RC4, and I haven't tried 21.02 yet.

image

Tbh I leave them empty, and just add one to /etc/resolv.conf when needed, it sticks until the next reboot.

1 Like

Thanks. For 21.02.0-rc4, I have to set dns in advanced tab. It works now!
image

Strange, on 19.07 I don't have to define dns.

1 Like

perhaps the older devices run off the DHCP, with or without static leases ... ?

The older APs running 19.07 also connected to the same pfSense ethernet port. Same settings.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.