Openwrt-21.02.0-rc3 Bridge interface stop working after enabling VLAN filtering

I thinks it is bag. After I adding VLAN filtering I can't access to the router.
But bridge is running and I can see all network connected to the bridge.
Pls Help !!!
Router mt7621 mqmaker board.


config device
option name 'br-lan'
option type 'bridge'
option macaddr '22:54:64:BD:81:89'
option bridge_empty '1'
option mtu '1500'
option stp '1'
list ports 'lan1'
list ports 'lan2'
list ports 'lan4'
list ports 'lan5'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.11.9'
option netmask '255.255.255.0'
option gateway '192.168.11.1'
option broadcast '192.168.11.255'

config bridge-vlan
option device 'br-lan'
option vlan '10'
list ports 'lan1'
list ports 'lan2'
list ports 'lan4:t'
list ports 'lan5'

@Leonid_Kristin
You need to set LAN's device to br-lan.10

@jow
We need a tagged<->untagged CPU port migration like how it was done in swconfig.

1 Like

Hello. Can you explain a little bit more I didn't get it.

Thanks a lot it works now!!!!

Not sure how a suitable algorithm for that would work. Migrate any "br-lan" users to "br-lan.X" upon declaring the first VLAN? What if the VLAN is deleted again? Or the ID changed? What if the "Local" flag is disabled? I am afraid that it'll be a lot more complex than swconfig.

How about similar solution like you did with swconfig to prevent softbricks: define always a vlan for lan already in the device default config definition.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=73d923ed6baabe3f8844f13216c50a6383a79a46

I have wondered if something similar is needed for DSA devices.