OpenWrt 21.02.0 - First Stable Release

Implying I don't fully understand the other side of the coin without saying what the other side of the coin is, well condescending. I guess I'm not smart enough for you to "understand"... seriously !

My point is that an upgrade from an OpenWrt partition if initiated from a dysfunctional install may also fail, which alleviates the Known Working State to recover from.

Some, including myself, have put themselves in peculiar situations where the current install is now unreliable/unstable/dysfunctional and the only fail safe way back is via the OEM partition and not via upgrading an install not going well at all, no other disrespect inferred otherwise.

I'm sorry the I don't have the ability to "understand"... Some people like myself are just so dumb...

I didn't go into detail because it's been done to death, both on the forum and the wiki.
[OpenWrt Wiki] Linksys WRT AC Series - Dual Firmware Flashing

I can see this has become an emotive issue for you. I'd suggest that if a read of the wiki doesn't allay your concerns that you open another topic for in-depth discussion (as this thread isn't the right place). I'd be happy to not participate further if you think my contributions have been insensitive so far. I don't have anything further to contribute that hasn't been said in the wiki anyway.

1 Like

@SlotTech You have to setup VLAN on DSA-based Switch using "config bridge-vlan" as mentioned at https://openwrt.org/docs/guide-user/network/dsa/dsa-mini-tutorial#multiple_networks_using_vlan_tagging .

Neither defining driver-level VLAN (https://openwrt.org/docs/guide-user/network/vlan/switch_configuration#creating_driver-level_vlans) in /etc/config/network for WAN switch port, nor just defining "option device 'wan.35'" in "config interface" section works for DSA-based switch ports.

Below config WORKED in my Netgear R7800 (dumb AP) running @hnyman's DSA build with @ansuel's patches.

config device
	option name 'switch0'
	option type 'bridge'
	list ports 'wan'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'switch0'
	option vlan '21'
	list ports 'wan:t'
	list ports 'lan1:u*'
	list ports 'lan3:u*'
	list ports 'lan4:u*'

config bridge-vlan
	option device 'switch0'
	option vlan '22'
	list ports 'wan:t'
	list ports 'lan2:u*'

config interface 'lan_1'
	option device 'switch0.21'
	option proto 'dhcp'
	option defaultroute '1'

config interface 'lan_2'
	option device 'switch0.22'
	option proto 'dhcp'
	option defaultroute '0'

Below config DID NOT WORK for me

config device
	option name 'wan.21'
	option type '8021q'
	option ifname 'wan'
	option vid '21'

config device
	option name 'wan.22'
	option type '8021q'
	option ifname 'wan'
	option vid '22'

config device
	option name 'bridge_1'
	option type 'bridge'
	list ports 'wan.21'
	list ports 'lan1'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'bridge_2'
	option type 'bridge'
	list ports 'wan.22'
	list ports 'lan2'

config interface 'lan_1'
	option device 'bridge_1'
	option proto 'dhcp'
	option defaultroute '1'

config interface 'lan_2'
	option device 'bridge_2'
	option proto 'dhcp'
	option defaultroute '0'
1 Like

isn't this a bit ot? I would move this to a separate discussion

Stunnel isn't working in this version. When it is executed manually it works, but when its launched from init.d script there's a message saying "no more addresses to connect".

don't mislead people

using factory.bin image with openwrt sysupgrade (LuCI) can result in bricking

sysupgrade.bin is the same image format for all devices (at least in a certain target),
factory.bin is different for (most) all device

however some specific devices have a unique upgrade script

in some cases factory.bin and sysupgrade.bin are the same thing

some devices cannot be upgraded via TFTP or other bootloader method, so factory.bin is a one-time-use image

sysupgrade.bin with all boxes unchecked is in (most) all cases the same as a "fresh factory.bin flash"

just say it depends on the device

2 Likes

Do you know who is the authoritative person I should ask in regard to moving an Archer C7 v2 from 18.x to 21.x safely?

The filesize difference is significant. 15 megs vs 5 megs between factory and sysupgrade and there is an architecture change combined with the warning that sysupgrade is not supported and that a "from scratch" install is required. I did not have an issue in the past using factory for incremental x.x.y increment updates.

I suppose I could just play it safe and just flash in 19 ath79 and then flash in 21 but it seems inefficient to do that. Would be good to get clarity on this for this specific device.

I'm not the "authoritative person", but I have been running LEDE (to OpenWRT) firmware for several years now, with no issues, on a C7 v2.

I recently flashed 21.02.0, decided to roll back to 19.07 temporarily, and started by flashing the OEM firmware, then the 18.06 factory (which I had on hand), followed by the 19.07.8 sysupgrade, and finally the 21.02.0 sysupgrade.

The whole process took less than 20 minutes.

There may be more "efficient" ways to do it, but this works for me, and follows the factory to sysupgrade succession process, which has never failed.

1 Like

Is the problem going from 18.06 to 21.02 a “programming the device” problem or is it a “keep the settings” problem?

Personally I doubt that it is a programming problem since every upgrade is a total rewrite of the memory on the device?

And if you haven’t left the discontinued 18.06 and installed 19.07 in over 2years now and now doesn’t have the very short time it takes to do a “double hop” if that is a requirement, what do you want us to do about it?

You can go directly from master to 21.02 or 19.07 or from 21.02 to 19.07. You only need to do two things in luci. Check the Force upgrade and do not keep settings.

I have done this process a lot this whole year in the project to make the ER 4 operational during the development of 21.02.0.

To downgrade and upgrade this firmware is not that big of a deal as long as the device is supported and you accept a clean install.

To first go to original firmware and the firmware flash is a lot of unneeded job.

Still missing GPIO support on x86-64 for intel SOC's like Atom E3950.
Why isn't it compiled from the beginning?

You really shouldn't be wasting your time with all that, there are downloads available for both factory and sysupgrade. There is no "sucesssion" process you're describing, just clutter and wasted extra writes to your flash. Things tend to get messed up doing it the way you did. The correct and cleanest path is factory straight to 21.02.

2 Likes

The OEM flash was for a test, so it was a one-off.

I don't do clean installs, so sysupgrade is the correct choice for us.

Has worked for several years.

1 Like

@hauke Good sir, would you be able to jump in here and state whether it is acceptable for a C7 in particular to flash factory.bin directly instead of a convoluted process of going to OEM or 19.x as an intermediate between 18.x and 21.x?

I believe it to be perfectly fine to do so, but others, perhaps for legacy reasons, do not feel this way.

I'm not sure what point you're trying to argue.

To me, a clean install is one that doesn't include any previous configs.

My configs carry over on a sysupgrade, which is my practice, unless I am flashing from OEM to OpenWRT, which would be a "clean install".

Never mind. Your post can be read as if your process of installing 21.02 now is OEM->18.06->19.07->20.02, and that would be pointless. But re-reading your post you have probably been doing that over a few years, which is of course fine.

Hi
Here happily using OpenWRT 21.02.0 stable in two devices: FritzBox 7412 and Linksys wrt1900acs v2. So far, everything working like charm :slight_smile:

The FritzBox is basically a modem-bridge, the Linksys is doing all rest of stuff, including vlans, pppoe, ds-lite, openvpn, apache, php, mariadb, ddns...

Just few things to remark, probably bad configurations on my side?:

  • The VDSL line is going down randomly. There are plenty of threads talking about this issue, pointing to the Lantiq firmware version. I am trying different versions... let's see which one wins, if any...
  • I've set uhttpd to listen to specific interfaces on both ipv4 and ipv6 for both 80 and 443 ports. After a normal reboot, uhttpd seems not to be listening on ipv6. But is has a simple solution:

/etc/init.d/uhttpd restart

Thanks, I did try this, and the line has now stayed up for over 7 days. When my ISP does retraining, it's usually an hour or two after midnight, localtime, so something may happen tonight.

I waited a full 30 minutes. It's not really troublesome, long enough for a meal.

On my Archer C7 hostname resolution does not work with 21.02. Relayd configuration

Guys I still have a device on 18, can it go direct to 21 or should I go 19 -> 20 -> 21?

Also I must have missed 20 I thought that wasnt out yet. O_o