OpenWrt 21.02.0 - First Stable Release

Can you show the exact commands and error messages that you are using when trying to install it (from SSH console)...

making it 21.02.0 / config-network-device aware might be good start...

The problem with WDS is still there.

https://bugs.openwrt.org/index.php?do=details&task_id=3961

I'll stay with RC3 till will be fixed. Thanks for your efforts

1 Like

Did not work on my WRT3200ACM. WLAN not working, several issues. I reverted to 19.07.8.

1 Like

OK. That's strange...
Installation via SSH works and wireguard is up and works.
It is just the installation via luci web interface which fails. Here is a screenshot:

3 Likes

mjpg-streamer DOES NOT WORK with OpenWrt's latest 21.02 update!
The router is NBG6617 and here's my topic about this annoying issue.

Help!

1 Like

Seems 21.02.0 is a bust for WRT3200ACM!

I have run my WRT's in dumb AP mode for years, basically following: https://openwrt.org/docs/guide-user/network/wifi/dumbap

I have been testing 21.02.0rc's and the first official release on my spare WRT1900ACv1 in dumb AP mode without any problems.

UPGRADE METHOD

  1. Flashed factory image using u-boot and tftp
  2. Enabled radios 0,1,2

WHAT WORKED

  1. Routes DHCP traffic to my pfsense firewall DHCP server.

WHAT DOES NOT WORK

  1. Will not route DNS traffic from WLAN to LAN side.
  2. Fails to start radio2 (WLAN2), missing MAC address

CONCLUSION

  1. Don't waste your time with 21.02.0 on WRT3200ACM.
  2. I am reverting back to 19.07.8

@LGA1150

3 Likes

I don't know why but now SQM is working fine on latest version. I didn't change anything on my build, just update/downgrade package to test.

Logs looks identical from v1.5.0-2 and v.1.5.1-1.

2 Likes

seeing this too... afaik has something to do with boot... switch over to layer_cake or something to debug properly for now ( and run it for a day between version switches when you switch versions... reboot )

Yeah, package management in luci has been flaky in 21.x

Sometimes it's there, sometimes... not. Just try again or use ssh. Maybe try a local mirror.

I think, that is a fair statement and I think it should be mentioned in the release notes that wrt3200 and wrt32x are devices that still have reasonable issues with 21.02 and should not (yet) upgrade to release 21.02.0.

The issues for these 2 mvebu devices are no surprise and have been around since the 21 rc* releases. This does not seem to apply for some of the other models of the same Linksys wrt series.

There are several threads in the install OpenWrt section discussing and debugging heavy issues for 3200 and 32x on 21.02 and it is not over yet.

The recent master releases seem to have fixed the bad issues for those particular 2 devices. But non- experienced users of wrt3200 and wrt32x should not upgrade to master images for everyday usage and probably rather stay on 19.07 for a while until a next fix release.

4 Likes

Could you send me your current /etc/config/network please (preferably from a router with a built in switch), I believe the solution is to replace ifname by ports (or rather add it, so the hotplug script stays backward compatible). But that is not a realistic root cause for the reported CPU overload.

1 Like

sorry mate... i've only got rpi4 and ipq806x (no dsa)

rpi4 config network device bits
config interface 'lan'
	option device 'br-lan'

config interface 'wan'
	option device 'eth1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

there also references in the dsa migration thread from rc2

Thanks, but it really looks that we need to add ports....

Do you really need radio 2? It's known to cause issues.

1 Like

Netgear R7800 - ipq806x : Update from 19.07.8 to 21.02.0 worked almost flawlessly with the following two exceptions:
(a) The 5 GHz band refuses to work with 160 GHz bandwidth and would switch on only with 80 MHz bandwidth enabled. (It worked fine with 160 MHz width in the 19.07.x builds).
(a) Samba had to be upgraded from samba36-server to samba4-server as the older package is not available with this build. It took a while, re-configuring all the peripherals connected to it, and would have been good to know beforehand.
Thank you to everyone who worked for this build.

Yes. Never had a problem with prior versions of OpenWrt/LEDE.

Still doesn't solve the other issues running 21.02.0 on WRT3200ACM

2 Likes

Thank you very much for the release of 21.02.0
Thanks to everyone who contributed.

My first with Openwrt 21.02.0 upgraded Device = Archer C7 V2 (Works perfect).
Next planed upgrade: RaspberryPi Zero

Greeting Robert

My Archer C7 v4 is running smooth as AP with the stable 21.02.
Thank you very much to everybody involved!

...supported by OpenWrt anyway. There are plenty of switches with x86 management CPUs out there. Random example: https://www.fs.com/de-en/products/107081.html

Lots of similar stuff out there. But they are usually running Cumulus or another switch specific OS. Would be fun to have OpenWrt there instead. Maybe a bit on the side the primary hardware targets. But so were the high port count Realtek switches until they suddenly were supported.

1 Like