OpenWrt 21.02.0 - First Stable Release

I do not have this issue on my WRT1900ACS. But I do not do nightly reboots, and am on a snapshot r17648.

1 Like

Question regarding OPKG package lists file distfeeds.conf:

I noticed that the 21.02.0 stable releases do not contain the src/gz openwrt_kmods line in the distfeeds.conf file. Is this expected?

I went back and saw that the 19.07.x stable releases and also the 21.02-SNAPSHOT builds still contain the src/gz openwrt_kmods line. But the line was removed starting with 21.02.0 RC1.

Do I need to add this line back in?

In particular, I am looking into the WRT3200ACM binary releases *wrt3200acm-squashfs-sysupgrade.bin when I noticed this.

Issue with VLANs on Fritzbox 4040. I created two VLANs. Strange thing is when i add WLAN to VLAN 2 (bridge) then WLAN does not retrieve any IP from the DHCP. LAN ports in VLAN2 works fine and receives an IP from DHCP. My workaround was now to create new WLAN interfaces and i seperated all interfaces with seperate IP ranges. This works for me. With 19.07.7 it was no problem to add a WLAN interface to a LAN interface and retrieve an IP in the same IP adress range. Anyone here with the same issue? The other features are working fine. Thanks to the developers for the great job!!!!

So, this release seems to be broken on the Netgear R7900.
Serial console debug session shows it hangs at: Decompressing Linux ..... Done, booting kernel

Then, nothing until power cycle. I tried "leaving it alone to see if it comes up", but 3 hours later, still no boot.

21.02 was installed clean via nmrpflash. Is this not the correct method? Had to go back to 19.07.8 for now.

I have 2 other routers in the house also, but I'm hesitant to try it, partly due to the above, and compounded by, the others don't have a serial console, and are still under warranty until January...

Does nobody have an answer, or am I being ignored. I have already tried making my own post/thread, but no response there.

Bootlog for this available here: Netgear R7900 Nighthawk hangs at bootup

Installed two days ago on a WRT1900ACSv2 and had 2 days of fun since trying to get WIFI and samba to work. Two days of wifi drops on all devices with no apparent reason or anything in the log files.
Samba 3 was removed from the repos, thus installed ksmbd. Only issue is that ksmbd simply did not work at all for some of my windows 10 apps, notably ACDSee Ultimate that kept crashing as soon as you accessed one of the ksmbd shares, tried all sorts of protocols, given up after a day. Installed samba 4 but for that first had to do extroot to get the available space. Samba4 at least worked then.

So my summary: Nice new UI with several improvements to luci, but under the hood a lot of broken things.

Reverted back to 19.07.8 today.

You posted 2 hrs. ago...and bumped after an hour.


OpenWRT does not have a 24x7 support staff waiting to answer questions.


Sorry, I do understand that. I originally posted about this several days ago, in a separate thread. That is where I seem to have been ignored. I should be more specific - and more patient...

If you have LuCI installed, try installing the sysupgrade using the UI, and don't keep the configs.

If not, try the upgrade using the CLI...

Alas, after my initial post, I have spent the last 2 hours trying those same 2 options. Same result.

Good idea, and nice try though!

I have also tried factory resetting the device, rebooting, and then installing the sysupgrade.

Also, FWIW, the install firmware and the sysupgrade firmware are the exact same - the wiki points to the same file for both.

You might try TFTP...

The problem doesn't seem to be in the hardware or in the procedure. The software is just buggy and doesn't boot. I am trying to report such. Not sure how to get a Dev's attention?

It's probably a fluke. The devs probably don't have this specific box available to test.

IF you get to it to boot, you may be thanked with buggy wifi, too. I have given up after two days of disconnecting clients and reverted. With all due respect, I think 21.02 needs a lot more testing before release.

I have a WRT1900ACSv2 and had heaps of disconnecting clients, Apple and Android alike. But nothing in the logs that would point to anything other than simple disconnect and reconnects multiple times a minute.
Given up, reverted to 19.07.

Did you try this


Thanks for the pointer.
Nope, googling did not find this - bad subject line I guess. Too late now. But I'll be watching the space.
No prob, will try again in a few months. :slight_smile:

With the device having two partitions, keeping 19.x on one and 21.x on the other and flipping between is a pretty simple way to test things.

1 Like

OK am having horrible wifi problems on my 10 year old desktop. It does wifi via Azurewave AW-NE785H mini PCIe card. On pings to the router I get horrible packet loss, some times it can't connect at all, wpa says things like CTRL-EVENT-BEACON-LOSS CTRL-EVENT-BEACON-CHANGE init=BEACON_HINT type=UNKNOWN. The wifi was fine before updating to 21.02; and every other device can connect to 21.02 fine.

Anyone any idea of what changed with wifi that would make a 10 year old card very erratic? It was fine on 19.07 ...