OpenWrt 21.02.0 - First Stable Release

This means i will loose all config ?

Very bad news, thank you, first time i saw this message since years ( 6 or so). I am sorry but i can't reconfig all my router, firewall etc...

Again,search the forum, it aint that bad, there are just a few config files that get in the way, with network being the only real show stopper causing the soft-brick.

2 Likes

Has anybody similar problem with openwrt (latest).
I have laptops, ipad and chromecast in same wireless network.
I have TP-link C7 v2 and i have noted 5GHZ network working only with lower channels.
But actual problem is. I have set 5G ch36, so it network working fine and all can use internet (ipad,laptop, chromecast).
Problem is, if laptop or ipad change 5Ghz network and chromecast is still 5Ghz, then Chromecast share not found in this machine.
If i change Ipad or laptop 2.4Ghz it can find chromecast, what still is 5Ghz.
I understand if dififferent network cause problems, but now problems cause same network.

edit:
Back to version 21.02.0 stable, all working well. Problems happen with newer version.

Hello, does Fritzbox 4040 support Distributed Switch Architecture (DSA) with this release or the old swconfig? Thank you!

The Fritzbox 4040 is based on the IPQ4018 SoC and still uses swconfig, not DSA.

Please note:

4 Likes

Is ASUS RT-N56U B1 supported? I see it in mt7621 target: https://downloads.openwrt.org/releases/21.02.0/targets/ramips/mt7621/openwrt-21.02.0-ramips-mt7621-asus_rt-n56u-b1-squashfs-sysupgrade.bin

Yes.

1 Like

upgraded today my second site's mqmaker witi-256m with a dirty hack (restoring backup - without network config) - only issue was luci (KO) but quickly found a fix on a google search https://techoverflow.net/2021/05/04/how-i-fixed-openwrt-luci-error-etc-config-luci-seems-to-be-corrupt-unable-to-find-section-main/
Only major downside is that openwrt comes by default wifi WIFI disabled - had to use imagebuilder with this workaround
Guys - we really need something like this ASAP - next release and backport to 21.02 !!!!

I have been noticing infrequent but intermittent failure (x3) of my WRT1900ACSv2 5Ghz networks (wlan0) internet connectivity after scheduled nocturnal reboot. This issue fixes itself after I manually reboot the router from the Luci settings (via 2.4ghz wlan1), but is affecting my long term stability. Reviewing the system log, I've noticed the following. Please let me know if anyone is experiencing these issues. Considering trying my luck with the master build, but I also wonder if someone has found a work-around.

  * daemon.err modprobe: failed to find a module named act_ipt
  * daemon.err collectd: rrdtool plugin: rrd_update_r failed: /tmp/rrd/OpenWrt/cpu-0/percent-softirq.rrd: opening '/tmp/rrd/OpenWrt/cpu-0/percent-softirq.rrd': No such file or directory
  * daemon.err collectd: rrdtool plugin: rrd_update_r failed: /tmp/rrd/OpenWrt/cpu-1/percent-interrupt.rrd: opening '/tmp/rrd/OpenWrt/cpu-1/percent-interrupt.rrd': No such file or directory
  * kern.err kernel: wlan0: failed to remove key (0, xx.xx.xx.xx.xx.xx) from hardware (-5)
  * kern.err kernel: wlan0-1: failed to remove key (0, xx.xx.xx.xx.xx.xx) from hardware (-5)

Until then, I'll implement watchcat on a wlan0 network and see if this can recover the stable state.

Cudy WR1300 updated just fine from RC4, no issues

Other than using the old swconfig, the 4040 works nicely with this new release.

I do not have this issue on my WRT1900ACS. But I do not do nightly reboots, and am on a snapshot r17648.

1 Like

Question regarding OPKG package lists file distfeeds.conf:

I noticed that the 21.02.0 stable releases do not contain the src/gz openwrt_kmods line in the distfeeds.conf file. Is this expected?

I went back and saw that the 19.07.x stable releases and also the 21.02-SNAPSHOT builds still contain the src/gz openwrt_kmods line. But the line was removed starting with 21.02.0 RC1.

Do I need to add this line back in?

In particular, I am looking into the WRT3200ACM binary releases *wrt3200acm-squashfs-sysupgrade.bin when I noticed this.

Issue with VLANs on Fritzbox 4040. I created two VLANs. Strange thing is when i add WLAN to VLAN 2 (bridge) then WLAN does not retrieve any IP from the DHCP. LAN ports in VLAN2 works fine and receives an IP from DHCP. My workaround was now to create new WLAN interfaces and i seperated all interfaces with seperate IP ranges. This works for me. With 19.07.7 it was no problem to add a WLAN interface to a LAN interface and retrieve an IP in the same IP adress range. Anyone here with the same issue? The other features are working fine. Thanks to the developers for the great job!!!!

So, this release seems to be broken on the Netgear R7900.
Serial console debug session shows it hangs at: Decompressing Linux ..... Done, booting kernel

Then, nothing until power cycle. I tried "leaving it alone to see if it comes up", but 3 hours later, still no boot.

21.02 was installed clean via nmrpflash. Is this not the correct method? Had to go back to 19.07.8 for now.

I have 2 other routers in the house also, but I'm hesitant to try it, partly due to the above, and compounded by, the others don't have a serial console, and are still under warranty until January...

Does nobody have an answer, or am I being ignored. I have already tried making my own post/thread, but no response there.

Bootlog for this available here: Netgear R7900 Nighthawk hangs at bootup

Installed two days ago on a WRT1900ACSv2 and had 2 days of fun since trying to get WIFI and samba to work. Two days of wifi drops on all devices with no apparent reason or anything in the log files.
Samba 3 was removed from the repos, thus installed ksmbd. Only issue is that ksmbd simply did not work at all for some of my windows 10 apps, notably ACDSee Ultimate that kept crashing as soon as you accessed one of the ksmbd shares, tried all sorts of protocols, given up after a day. Installed samba 4 but for that first had to do extroot to get the available space. Samba4 at least worked then.

So my summary: Nice new UI with several improvements to luci, but under the hood a lot of broken things.

Reverted back to 19.07.8 today.

You posted 2 hrs. ago...and bumped after an hour.

Relax.

OpenWRT does not have a 24x7 support staff waiting to answer questions.

5 Likes