OpenWrt 21.02.0 - First Stable Release

I believe that should be a single ">" as you want to overwrite, not append.

You cannot disable 802.11w if using WPA3 in any way. The setting will revert to optional.

An unfinished product that is presented as stable, especially in the luci (general) section.
ddns does not work well, https mode does not work well, very small letters in the boxes, misplaced boxes. In the end they will make me buy those 5x glasses that I always want to weld fine, but I will use them to read the openwrt webui
In short, a stable firmware that seems to be made of pieces cannot be presented.
You have seen the luci-app section ....
It,s my opinion....and my experience with this release sorry adeu.

fd dimoni

Are you troll?
DDNS work well on x86
HTTPS work well on x86
No small letters lol.
No misplaced boxes lol.

don't listen him.. everything worked well, i've swithed to snapshot due to 5.10 kernel, but 21.02.0 was rock solid for me,

1 Like

I would guess he wasn't using WPA3. I run a WRT1900ACS and for the first 3 weeks I also had 802.11w disabled with WPA2 only, as indeed there are many reports of a mixed mode not working out.

After 2+ weeks of a stable 21.02, yesterday I moved the 5 GHz from WPA2 to 3, and 802.11w from disabled to enabled to try it out. I was surprised to have seen a very stable wifi with WPA3 (24h uptime now). But on the 5GHz all my devices are WPA3 capable. I guess the real test will be with a mixed mode on the 2.4 GHz as I have many devices that cannot use WPA3.

I had the same issues you describe on rc4. They faded when I moved to 21.02.0 with similar settings as @User34 (though I now moved the 5 GHz to WPA3). FWIW There is a whole thread on this issue for the WRT32X.

1 Like

That thread doesn't apply to a WRT1900ACS as the wireless chip is different.

I know the chip is different. Nevertheless they were nice and welcoming to also discuss it there despite the title. Especially since the root cause of the issue is not yet clear, I'm not even sure it was pinpointed to the chip yet.

Yea it was an absurd reply. 21.02 is an impressive release and DSA was a huge undertaking, but it's the right thing to do moving upstream I would say. I switched my WRT32X to master snapshots because of kernel 5.10, gcc 11, and most importantly wifi is more stable (21.02 seems to have an issue much less present in master). But it's a great release. My only disapointment is the LuCI theme, there should at least be a dark mode. Model a dark grey/blue color sceheme off tomato or even the oem wrt32x firmware with the same bootstrap interface would have been fine.

4 Likes

It's a device file and double redirect makes sense

1 Like

You are right. When I first set up OpenWRT I was using WPA2. Later on I enabled WP3/WPA2 mixed mode. So right now it is reverted to optional. This is why I'm not sure if it makes a difference. I've been using mixed mode for a while now, but I think I only have a handful of WPA3 capable devices, and I'm not sure which is being used by each device.

Fully agree with you that 802.11w config does not seem to make a difference, at least not with this series of WRT + current stable release. I started with disabled like you and now have moved to enabled on 5GHz, and optional on 2.4. Did not see any difference in stability, speed nor latency. Not that WPA3 really matters to me as there is maybe no difference in terms of security as I still have to live with the mixed mode until I change all legacy devices (which won't happen so soon).

Exactly. Not throwing away any old devices today.

When you switch back and forth between master and 21.02 did you have to throw away your configuration file? Not noticing significant WiFi problems with 21.02, but I don't long to rebuild my config just to see if it's more green on that side of the fence.

Yea I do, but it only takes me 10 min to reinstall the packages with opkg and fully reconfigure my wrt32x. I've done it many times have a little personal guide and settings written that I basically just copy and paste in and reboot. I always leave the OEM firmware on the second partition just in case.

1 Like

There is a huge issue.
CONFIG_TCP_MD5SIG is not activated anymore by default in the kernel, and this breaks a lot of packages like bird, frr and quagga which needs TCP MD5 support. So it has to be configured my using make kernel_menuconfig . In master branch it's still active. I think that's a major issue.

I try to upgrade my wrt1900acs from OpenWrt 19.07.8 but it failed.

I downloaded openwrt-21.02.0-mvebu-cortexa9-linksys_wrt1900acs-squashfs-sysupgrade.bin and when i tried to flash i got this message :
Warning

so i checked "Force upgrade" and nothing happened, no light were on, no reboot. I loss the connection with the router, so i reset and start/stop the switch and it came back to 19.07.8

So what i have to do ?

and uncheck keep settings

Edit: Yes, you will find many threads about how to deal with issue.

1 Like

This means i will loose all config ?

Very bad news, thank you, first time i saw this message since years ( 6 or so). I am sorry but i can't reconfig all my router, firewall etc...