Openwrt 19.07 RC1 Archer C7 V2 5G wifi died after trying to change channels

You need to install hostapd-openssl or hostapd-wolfssl package and restart router to get wpa3 in menus.

Mon Nov 11 00:34:46 2019 daemon.notice hostapd: wlan0: DFS-CAC-COMPLETED success=0 freq=5580 ht_enabled=0 chan_offset=0 chan_width=3 cf1=5610 cf2=0

ht_enabled = 0
Mon Nov 11 00:34:48 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0

Maybe it's not really disabled... Can you post your sanitized (no passwords) /etc/config/wireless and /var/run/hostapd-phy0.conf?

wireless https://pastebin.com/3DNPt8Ve
hostapd https://pastebin.com/Wrm6TGC9

Passwords removed. In LuCi I have AC and N modes selected.

EDIT

Rebooted router to get 5G working again.

Nevermind, hw_mode of a is fine

From reboot
logread https://pastebin.com/u6kbcjwV
wireless https://pastebin.com/NWdpV6wp
hostapd https://pastebin.com/z8s34w9M

Seems like the same issue, even the same device

But I can bring 5G back to life by rebooting device. And it was working correctly on 18.06. Now that I think I changed to hostapd-openssl for WPA3. Maybe issue is there?

EDIT

Any way to fix this or just rollback and wait for next RC?

CAC completed success=0 is not good.

Channel 42 should be selected to use 80 MHz in the low part of the 5 GHz band. Though I think modern drivers will accept any channel from 36 to 48 and work the same.

The actual connect speed depends on the client. And one slow client that declares itself "intolerant" can slow down the whole radio. If with no clients connected, you see width: 80 MHz in the output of iw dev, the interface has been set up for potentially 80 MHz.

look at my post above, it doesn't work properly with latest linux drivers

In my case I'm using AX200 on Windows 10. And it was working with 80mhz before on 18.06.

I have the same router as you. I am not using WPA3, only WPA2. I have installed only wpad-basic and have no problems with Wi-FI performance.

I'm seeing difference. On my page it says "Qualcomm Atheros QCA9880 802.11nac" on yours ""Qualcomm Atheros QCA9880 802.11acn". Are you using RC1 build?

Hi,
Yes, I am using 19.07 RC1.
This is my /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option country 'BG'
	option legacy_rates '0'
	option channel '48'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Home_5G'
	option key 'Key-Removed'
	option encryption 'psk2+ccmp'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ahb/ahb:apb/18100000.wmac'
	option country 'BG'
	option htmode 'HT40'
	option legacy_rates '0'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Home'
	option key 'Key-Removed'
	option encryption 'psk2+ccmp'

Ok, thats interesting. I basically copied yours file but changed ssid and key. And now I get
"780.0 Mbit/s, 80MHz, VHT-MCS 8, VHT-NSS 2, Short GI
468.0 Mbit/s, 80MHz, VHT-MCS 5, VHT-NSS 2"

EDIT

Unfortunately speedtest shows that issue is still there. 30 mbits dow/ 139 mbits up on 600 symmetric.

that doesn't make sense. what if you reset router to rc1 defaults and configure it from the scratch? (don't install ssl or other uneccesary packages)

No changes. Reset, reconfigured without touching additional packages. Showing 80mhz but speedtest is nowhere near what it should be.

and today it works fine with ath10k-ct driver? maybe your windows pulled some update that's why it connect at 80Mhz. otherwise i wouldn't trust test results while having router connected to the internet...

Although it might be the case but when on 18.06 I was getting 80mhz and around 300Mbit/s on speedtest. Also on the same router is PC connected on ethernet. Same speedtest gives results around 400Mbit/s. Well that issue is whole different story and questions where asked to the ISP.

I did tests with Speedtest and my speed matches the one that is expected


I have installed:
ath10k-firmware-qca988x-ct
kmod-ath
kmod-ath10k-ct
kmod-ath9k
kmod-ath9k-common

I have also enabled in the firewall page software flow offloading and hardware flow offloading. I do not use QoS/SQM, as it is stated it is not fully compatible.

This doesn't look like a compatible combination

Looking at the hostap code, I see, for example, from src/ap/dfs.c

static int dfs_is_chan_allowed(struct hostapd_channel_data *chan, int n_chans)
{
        /*
         * The tables contain first valid channel number based on channel width.
         * We will also choose this first channel as the control one.
         */
        int allowed_40[] = { 36, 44, 52, 60, 100, 108, 116, 124, 132, 149, 157,
                             184, 192 };
        /*
         * VHT80, valid channels based on center frequency:
         * 42, 58, 106, 122, 138, 155
         */
        int allowed_80[] = { 36, 52, 100, 116, 132, 149 };
        /*
         * VHT160 valid channels based on center frequency:
         * 50, 114
         */
        int allowed_160[] = { 36, 100 };

Or, from src/common/hw_features_common.c

int allowed_ht40_channel_pair(struct hostapd_hw_modes *mode, int pri_chan,
                              int sec_chan)
{
        int ok, first;
        int allowed[] = { 36, 44, 52, 60, 100, 108, 116, 124, 132, 140,
                          149, 157, 165, 184, 192 };