Openwrt-19.07 on Raspberry Pi 3 - opkg update / wget returned 4

hi everyone,
I install LuCI openwrt-19.07 on my raspberry pi and it works well, I haven't problem with wi-fi ecc but when I try to "Update List" it reply this:

Downloading http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/kmods/4.14.171-1-ae418ed2395263358bbe7536d318ae28/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/kmods/4.14.171-1-ae418ed2395263358bbe7536d318ae28/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/telephony/Packages.gz

Errors
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/targets/brcm2708/bcm2710/kmods/4.14.171-1-ae418ed2395263358bbe7536d318ae28/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.2/packages/aarch64_cortex-a53/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

The  *opkg update*  command failed with code  `7` .

I downloads the package and istall it manualy but it reply;

#### Executing package manager

##### Errors

Collected errors: * pkg_init_from_file: Malformed package file /tmp/upload.ipk.

The  *opkg install*  command failed with code  `255` .

What's happen??
Thanks

See https://openwrt.org/faq/failed_to_download_wget_returned_4