OpenWrt 19.07.1 ath79 tiny LuCI

@newbs thanks for letting me know.
I plan on building new OpenWRT 21.02 with LuCI if possible; hopefully it will fit and there won't be dependencies on SSL as even the smallest SSL implementation doesn't fit 4 MB flash size.

7 Likes

Hello.
I would love to see updated uPnP builds from 19.07.02 to version 19.07.7 - as i understand from reading this topic it has fixes for the bug that Samson mentioned a few posts above.
I have 841N v8 and 3420 v2 (and that one doesnt even have 19.07.02 uPnP build).

If there's a need to cut something else I'm OK with wpad-mini and even with lack of relayd.

Hi. Thank you very much for putting your effort and time on this. It makes our "tiny" (but awesome) devices comes alive again.

I'm a little lost. Were you able to add SQM in your 19.07.7 compilation??

My device is a WR940Nv6 and I'm looking for an updated firmware with SQM and IP Bandwidth Restrictions.

Thanks in advance! You're doing such a great job!

Ok, if there are some bugs fixed, here is 19.07.7 with uPnP:
https://openwrt.ashus.net/19.07.7-targets-ath79-tiny-luci-upnp/

Sorry, I tried, but even without relayd, SQM needs tc, ipmark, ifb and other stuff and it just doesn't fit 19.07 builds. You need a hardware upgrade - preferably to Archer C7.

That is so sad.

So, it means that this one won't work properly?

It could work fine. I think those mentioned features are a list of the ones excluded from the builds. It only makes sense to remove opkg on tiny devices where you can't install anything anyway.

1 Like

Is it possible you may take a look on that please? I love your excellent work, you're always up to date, and I think it will be the best if you could implement those features that let us have an optimal broadband management (even if you delete or exclude anything else).

Sorry for my bad English. My apologies

...and it doesn't matter if you could add it not in latest version. If you do it on 19.07.1 or .4 it's gonna be wonderful

hey, great job with these tiny releases, i wont bother asking u for images without specific packages, but would u maybe share the imagebuilder file with us ? i tend to change old hardware to dump AP's without tcp v6 so it would be helpful

If you mean the .config file, it is already included, so you can make modifications easily.

2 Likes

You have done an excellent work with this! I'm trying your last 21.02 build for the wr841nd-v8, it works!

For some of us, it is easier to generate firmware images, using the Image Builder instead of the full Build system setup. For example, I would like try to add SQM for the wr841nd-v8, maybe removing ppp, ipv6, opkg, dnsmasq and something more like firewall, because I'm using the Device as a Repeater and also I want to assign a bandwith limit for each Wireless SSID Interface I have usin SQM. It's possible to upload the image-builder file, ready to create wr841nd-v8 image to your Online Folder?

1 Like

Hi, I'm sorry, but from what I read, the image builder accepts arguments which packages to include or exclude. Maybe you can use my generated config and compare it to the defaults to build it. Or you can set up the whole thing and compile it the standard way.
IMO you can't fit later OpenWRT versions with SQM into 4MB ROM devices. Go for an upgrade to Archer C7 if you want to stay with TP-Link with dual-band wifi with 802.11ac.

@Ashus Hello
First of all, thanks for the build, it's running quite well on my 841n v11 :smiley: Though except for the wireless part.
I was doing research on openwrt on those cheap tp-link routers and I stumbled upon your build of openwrt. Seeing you've removed some unnecessary stuff, I thought why not give my 841n a try.
So I downloaded your build, got a tftp server running to serve the firmware, got into u-boot prompt and manually wrote the firmware into the flash (the reset button recovery method didn't really work, it did download the firmware but didn't write it to the flash, strange).
After some initial setup, I got it working with a wired connection but there's no option to change wireless settings. I checked the kernel log and saw these 6 lines:

[   13.756969] ath: EEPROM regdomain: 0xe1fa
[   13.756981] ath: EEPROM indicates we should expect a country code
[   13.756998] ath: invalid regulatory domain/country code 0xa1fa
[   13.757001] ath: Invalid EEPROM contents
[   13.761147] ath9k 18100000.wmac: failed to initialize device
[   13.767062] ath9k: probe of 18100000.wmac failed with error -22

ifconfig or ip a didn't yield anything about the wireless interface. I came here from dd-wrt FYI, wondering if that might have affected something... Before flashing openwrt I flashed dd-wrt's wr841nv11_webrevert.bin to revert back to tp-link's stock firmware. Then strangely it didn't give my PC any IP address at all nor did it have any AP broadcasted. I shrugged off then did a manual install of your openwrt build. And now there's that. I doubt dd-wrt's web revert firmware overwrote the ART partition.

Do you have any idea what to do to get wifi running? I do have the flash's full backup here (all partitions on it) dumped from its stock firmware before I installed dd-wrt (including the ART partition, yes).
I'd really appreciate your help!!
OpenWRT really is better than dd-wrt at some points (i decided to switch to openwrt cause' dd-wrt doesn't have ipv6 support for 4/32 devices)

I'd try to change the configured country on the wifi interface a few times. If it doesn't help and you still have the backups, try to upload them all back to get stock working as it was in the beginning. Maybe even do factory reset after flashing stock. Besides that, I don't think I can help you.

Hi, do you have any older version with SQM working fine??

Thanks in advance

@Jebnael Sorry, SQM needs a lot of space. I've seen some 18.06 builds with SQM support. Maybe someone could fit it to a custom build of 19.07 with much other things removed. But IMO there is no way it could fit into 21.02 build.

Guys, new version 21.02.0 is compiled here:

Thank you very much @Ashus. You're doing an excellent job with this. I'm just looking for an old version, like 18.x or 17.x but with SQM working on it.

What can I do for managing my broadband with this version that you compile?
Will it improve the quality of my connection? Will it improve the bufferbloat?

Thanks. Since you didn't mention what device you have, maybe this could help you:

My apologies. WR940N v6