OpenWrt 19.07.0 / WRT32X / hostapd 2.9 -> usable?

Hi all,

I've just seen the problem reports in OpenWrt 19.07.0 second release candidate and asking myself, if it is a good idea to use 19.07.0 on this device or if it is better to wait for a possible 19.07.1?

Has anyone used the 19.07.0 RC2 on this device and can say something to the Wifi (especially 5GHZ) and its behavior regarding hostapd 2.9?

Thanks and best regards

The 19.07.0 release is supposed to fix all the issues detected on the release candidates, you do not need to wait for 19.07.1.

1 Like

People have been pointing to hostapd 2.9 as the culprit for a few issues in the past weeks, and ynezz has a staging tree with a hostapd bump containing quite a few fixes. The ath10k-ct issue killing wireless has been addressed it seems, which is what most ath10k users seemed to run into, but it looks like hostapd might be creating issues.


yes, i've seen the same on trunk. it makes out its own version of interface crash, completely unrelated to the driver, and refuses to bring up interface unless rebooted...

1 Like

Thanks for your replies. Wifi seems to work for now.

Unfortunately cannot get Unbound to work, it ends in a crash loop. I think I habe to revert to 18.06.5 until its fixed.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

No issues with Unbound here and I have been running (pre) 19.07 builds for quite a while. Better check first what's actually going wrong (and file a bug) before just reverting to 18.06 - if it's a reproducible issue it will just pop up again in 19.07.1 and so on...

The problem is I have no idea how to track this down. Also with increased loglevel there are no more log messages which are helping here.

I've used unbound for a long time now with exact (scripted uci settings) the same setup and no problem.

Best regards

Because its a production system I've reverted to 18.06 (.6) and everything is back to normal now.

What I've done before is to reset 19.07.0 completly to stock and installed unbound-daemon. It was crashing. After setting dnsmasq to another port it seems to run. But this cannot be my problem, because thats also done by my setup script and I've checked if something is listening to port 53 after setup. There was nothing.

All things done by my setting on the unbound and dnsmasq config are not the problem (at least I think so). After reverting them step by step unbound was also crashing. Because everything else is (many but only) uci firewall and network config + some switch stuff for vlans I don't know whats the problem.

Best regards

Did you save any logs?

No. There was nothing special in the log. Only 4 lines regarding unbound:

  • 3 lines that its using defaults for memory, protocol and another setting I forgot -> normal bevaiour
  • 1 line 30 seconds after start about the crash loop

In any other way the log was clean. I have also stopped any other running services except uhttpd and dropbear. Same result.

If you want I can cleanup my setup from the sensible information and upload it here? Maybe this helps with analysis.

Best regards

It would be better to create an issue at the proper place

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.