OpenWrt 19.07.0 first release candidate

No image = image too big to fit the flash 99% of the time.

High latency on wifi its fixed in davidc502 build

The router does not work after installing

Your problem is then not of the class "Images for some device became too big to support a persistent overlay, causing such models to lose configuration after a reboot."

Did you analyze what does not work after installing?

1 Like

Having been waiting for forever for a stable non-snapshot build for my TP-Link Archer A7 v5, I happily flashed my router today.

Incredibly easy to flash and configure. Best of all, because I used the same SSID and password, all my devices reconnected without issue.

Even better, the problem I had with 5GHz connections dropping randomly using the "official" firmware seems to have gone away entirely now that I'm using OpenWrt.

Thank you very much for this release.


Tested OK. Waiting for final release.

Next release candidate version rc2 was tagged yesterday and is being built by the buildbot right now. About 25% of the images have been built so far... The build will take 1-2 days, so the 19.07.0-rc2 announcement might come in a few days.;a=shortlog;h=628e9969288a605565793358bf7468276b8774e6


Good news!

Looking forward to testing rc2. My EA6350v3 loses wifi after a couple days of growing memory use followed by automatic process killing. The unit is not particularly stressed - running as an AP with ~4 2.4G clients, ~2 5G clients and 2 wired clients. I captured a memory plot, syslog and kernel log here: 20191201 EA6350 v3 19-07 rc1 Memory-Crash Issues.odt

I've tried latest snapshot and have the same issue (actually started there, and dropped back to rc1 hoping it might resolve it).

@eginnc, try replacing the ath10k driver and firmware with the non -ct version. This can be done with a simple opkg remove and install.

@eginnc Please file a bug here as well so devs can follow up on it.

Bug report filed:

Installed RC2 without issue on WRT3200ACM. Thanks to the entire team!

1 Like

Perhaps RC2 issues should be discussed in a separate RC2 topic.


I can not access the router because it does not boot

Reinstalled RC2 on TP-LINK TD-W8970 flawlessly with the luci interface. So far, so good, 24 hours under moderate load without issues.

I would only recommend saving cascade.css of luci between reinstalls. I do not like the default bright colours. Btw. could I find somewhere a kind of dark mode for the luci interface?

Thank you so much for the great software.

See /etc/sysupgrade.conf and add its path to that list.

For "official" themes, see[Name_pkg-dependencies*~]=theme

1 Like

@mk24 Follow-up on your suggestion. I tried removing the ct ath10k package (and kernel companion) and replacing with the non-ct 4019 versions. I let it run for the day and results are mixed. It hasn't crashed yet (EDIT: it crashed - the oom_reaper needed to start doing its thing overnight and dmesg logs show the wifi was disabled), but doesn't appear long before it will (EDIT: sure enough). Results are not good. Memory usage is still way too high for the load (~150MB). Connection times are so bad with the non ct packages that some devices gave up, and 5G speed and signal to noise are terrible. So the CT ath10k stuff has its advantages to be sure. Inexplicably, repetitive log message complaints about "Invalid legacy rate 26 peer stats" stopped about the same time memory usage dived back down to ~50MB (where I expect it should be for the the load) with no apparent reason. I don't have support legacy rates checked, but I've nothing so old it uses 802.11b in the house. Bottom line, sadly, I couldn't narrow the problem down to ath10k-ct by replacing it. Memory graphs and log extracts here if interested: 20191203 EA6350 v3 19.07 rc2 non-ct ath10k.odt

Since we now have OpenWrt 19.07.0 second release candidate, please try out RC2 and report back any issues in the linked topic.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.