OpenWrt 19.07.0 first release candidate

please do not delete the tiny ar71xx at 19.07 and all the latest versions to come

Thanks so much for the great system. I debricked my old-and-almost-in-a-trash-can TP-LINK 8790 (v1) via serial console, and the lantix branch works great. I installed firstly 18.04.06. A days-two ago I updated to 19.07-0-rc1 via LUCI, and the new version appears stable (fingers crossed).

Among many improvements, I appreciate very much the wifi scheduler which did not work properly on 18.04.06.

You guys are awesome!

1 Like

Thanks for the excellent work! Updated my Linksys WRT3200acm, everything seems to work fine.

The only thing I recognized and wanted to share: If you run a EU-version of the router, one has to manually set FR (France) as WiFi country code to enable DFS. Setting it to "driver default" won't work.

1 Like

I updated my Linksys WRT3200ACM too. I have a little issue with the installation for the package Watchcat. The installation take more time to install than normal and the pop-up window from LuCI freezed. It does not give any option to close the pop-up window once the installation is done and you have to refresh the browser manually.

TP-Link Archer C7 V2 -

Wireless lights on router off.

Static IP's all marked as expired.

1 Like

19.07.0-rc1: Swap doesn't work on D-Link DIR-620 D1 (ramips/rt305x)

Awesome update.

Question––is it now "safe" to run opkg upgrade, or at least upgrade all these packages in LuCI?

I would not assume that it is safe to run opkg upgrade -- AFAIK, the system still doesn't have compatibility checks that would notify/prevent/upgrade-dependencies, so things may still break.

My general advice is to only perform your upgrades by means of flashing a new build (release, snapshot, etc.). If there is a new feature or bug fix that you must have sooner than it would otherwise be included in an official build, it is probably best to ensure you have a good backup and then run the upgrade only for the specific package(s) in question. If something breaks, you can always reset to defaults and restore your backup.

1 Like

i need none of the new features but look forward to flashing it anyway once its finalized

Please add this patch to make work extroot on Zyxel Armor Z2 (NBG6817).
It perfect work for me on the current master now.

There is a theme about it.

1 Like

Well... possibly add something similar.... generified.... handling UBIFS only in release would be premature IMHO.

1 Like

Now it work corrects except mounting extroot.

System on boot searching fstab file in wrong place on this router: /etc/config/fstab instead of /tmp/overlay/upper/etc/config/fsab and doesn't find. For this reason extroot doesn't automatic mount at boot.

I can connect by ssh after boot and mount it by hand, but not as /overlay.

This patch solve auto mount problem.

It would be great to add it at least to the master (now it perfect working on master) and after that back port it to the current release.

why no more squashfs for 'tiny' branch, only initramfs ?


Any ETA when all packages will be made available for installation ? I have tried to install a couple of packages for my Linksys WRT3200ACM but i am getting the below error message:

Collected errors:

I have tried to run opkg update but that did not work, it looks like a lot of packages are missing. The "Advance Reboot" is also missing from the package source.

Thank you!

Update Never mind, everything is working fine now :smile:

BT HumeHub5a upgrade from 18.06.5 to 19.07.0-rc1.

Success, it looks like I needed to add option proto 'none' to my definition of the VDSL-to-ethernet bridge and/or change the modem firmeware to a more modern version. But after doing both the upgrade seems to work just fine.

On Netgear R7800 it seems that AC 160Mhz still doesn't work, but this time I wasn't able to get wireless working again by switching back from 160Mhz mode. Had to factory reset.

No AC wifi by default on Archer C7 as reported here

Upgraded my R7800 using the sysupgrade file. Works perfectly. All devices are connecting. WPA3 support is working on a Pixel 3 and iPhone 8. I cannot connect my Linux laptop via WPA-3 though. WPA-2 works.

I don't see any benefits from the switch from ath10k to the "-CT" out-of-tree driver... Should I?

While slightly beyond topic, desktop linux (depending on the wireless card/ driver; not all support IEEE 802.11w, which is mandatory for WPA3) should be the easiest to configure as WPA3/ SAE client.


        id_str="some identifier"

should work, provided you have a recent wpa_supplicant (>=v2.7, better >=v2.8) installed and are running a kernel >=v3.8.

Building on any system that defaults python 2 is going to fail. That means Debian 9 (oldstable), and pretty much every linux installed before last year.


Otherwise built okay and tested on an ipq8064 system.

1 Like