OpenWrt 18.06.8 service release


The OpenWrt Community is proud to announce the eighth service release of the stable OpenWrt 18.06 series. OpenWrt 18.06.8 brings security fixes, as well as the usual device support fixes and core components update.

The main highlights of this service release are:

  • fix a ppp buffer overflow vulnerability CVE-2020-8597
  • fix a libubox regression in 18.06.7 that caused umdns to stop working
  • update Linux kernel from 4.9.211 to 4.9.214 and from 4.14.167 to 4.14.171
  • device support fixes for RB912UAG-5HPnD r2

Additional release notes are available, as well detailed list of all changes since 18.06.7.

For latest information about the 18.06 series, refer to the wiki page.

To download the v18.06.8 images, navigate to download page.

As always, a big thank you goes to all our active package maintainers, testers, documenters, and supporters.

Have fun!

The OpenWrt Community


Works fine, thank you!

However it gets DNS servers by DHCP, placing them below specified:

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option peernds '0'
        list dns ''
        list dns ''

IPv4 Upstream
Protocol: DHCP client
Address: XX.YY.ZZ.TT
Gateway: XX.YY.ZZ.10
DNS 1:
DNS 2:

I have a bad news for this new release when i update my router tp-link wr941nd v3 and tried to login but instead page with user name and password i getting follow message:

/usr/lib/lua/luci/dispatcher.lua:234: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:234: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

then i decide to back to releases 18.06.7 with follows commands:

ssh root@192.168.X.X
cd /tmp;wget $DOWNLOAD_LINK;wget $SHA256SUMS;sha256sum -c sha256sums 2>/dev/null|grep OK
sysupgrade -v /tmp/*.bin

and now everything works fine so i guess that in a new release has i little problem.

The same happens on TP-Link 841v9.

Solution from Upgrade Broke Luci do not solve the Problem.

Same issue with openwrt-18.06.8-ar71xx-tiny-tl-wr841-v7-squashfs-sysupgrade.bin upgrade from 18.06.7 to 18.06.8 breaks luci, rolling back to 18.06.7 works. with the error message:
/usr/lib/lua/luci/dispatcher.lua:234: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:234: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

Here is the config:


config core 'main'
	option lang 'auto'
	option resourcebase '/luci-static/resources'
	option mediaurlbase '/luci-static/bootstrap'

config extern 'flash_keep'
	option uci '/etc/config/'
	option dropbear '/etc/dropbear/'
	option openvpn '/etc/openvpn/'
	option passwd '/etc/passwd'
	option opkg '/etc/opkg.conf'
	option firewall '/etc/firewall.user'
	option uploads '/lib/uci/upload/'

config internal 'languages'

config internal 'sauth'
	option sessionpath '/tmp/luci-sessions'
	option sessiontime '3600'

config internal 'ccache'
	option enable '1'

config internal 'themes'
	option Bootstrap '/luci-static/bootstrap'

config internal 'diag'
	option dns ''
	option ping ''
	option route ''
1 Like

Hi, openwrtfan1, I have your issue (LuCI WebGui broken) with the same version of OpenWrt.
I can connect to SSH but I don't know the command to roll back.
Could you tell me how to do it?
Thank you
Carlo Gazz

There have been a couple of reports regarding such behaviour in this forum. You can read more (and some hints on how to fix it here): Recent upgrade broke Luci

Thanks "thedukesd", I find in post#48 by Fperuso the solution.
As soon as I can, I'll do the repair.

In the reply to @jow - first part of the post I presented the fix that worked for me:

thanks justme123, jow's fix worked. I wonder why the ubus socket times out and how they figured out that was the problem.