OpenWrt 18.06.2 TL-WA830RE reset button doesn't work


i have set lan as DHCP client, my fault and cant access the web gui anymore. The rooter isnt pingable anymore.

Than i tried the reset method, i hold the reset button and plugged the router in. But there is no rapid flash light blinking. It restarts permanantly after a 10 - 15 seconds holding of the restart button. Than i tried to push the reset button in a high frequenz, this method has no effect.

I think the button is wrong programmed. The front button für WPS connect has no effect.

Is the rooter now garbage, if I have no serial adapter ?

Best regards


You could run a dhcp server on another PC/router in your lan and as soon as openwrt acquires an IP from it, login and revert.

1 Like

Tried it. It gets no ip address from the dhcp server.

But why is the fail save mode not working ?

Could you test please, if the reset button is working on your version of openwrt18.06.2 ?

Maybe its a software bug, which is infecting all routers of this software version.

It would be fatal if several routers could been bricked, because of a software bug.

  • Odd, are you sure you plugged it into one of the LAN ports?
  • Likely, because you haven't activated it

Perhaps, you should wait a few seconds after plug in. You have to play with this. I suggest that; because on my router - that would cause it to enter the OEM flashing mode, not OpenWrt Failsafe.

  • My reset button reboots the device when booted up
  • But as I noted my router has an OEM flash mode on the reset button, I cannot easily test the Failsafe you desire
  • You should always have a serial adapter on hand
  • I suggest trying to see if you have an IPv6 ULA address on the interface - if so, you should be able to access the router via this IP

I have connected it to the lan port of the dhcp router. No address has been related to the Open WRT router.

I've waited a few seconds. Than is started to push the reset button. Than it also reboots.

Firmware versions before it works like it should. Without any issues.

Windows 10 and the open wrt router which is running the DHCP server has not offered any ipv4 or ipv6 adress to the bricked openwrt router.

I think the router is done. Sadly.

Why don't you just buy a serial cable to enter failsafe and revert it?

1 Like

You have to solder it ?

  • You haven't described a bricked router
  • I didn't say the DHCP server needs to issue an ULA address, the device should have one already!

Which ULA address shoud i set, and which address should i use for access on the router ?


Nevermind...if you don't have a copy of your config, this likely won't work. You'll need to play with Failsafe - or get a Serial cable.

I would surmise something like xxxx:xxxx:xxxx::1; but if you don't have a config, you won't know the ULA prefix.

I've tried all possibilities for triggering the fail safe mode. I think the firmware is causing the issue with reset button which ist not related to the fail safe mode.

I wasn't able to find the board diagram in Openwrt wiki, so you'll have to do some research yourself on that. However even if there are no pins ready for console connection, you can bend a small wire to connect the hole with the serial cable. Just be careful not to touch each other.
Before you go into that, have you tried if the device goes into the default IP ? ( )

1 Like does not work. Whenever i push the restart button, it restarts only after 5 - 10 s push.

Nothing else happening. Its frustrating.

Take a high resolution photo of the board to verify that there are console pins.

I think we have garbage in front of us here. No console pins.

Yes console pins.


(Also, please use the image upload button in the future.)

Please link a suitable adapter on I think i will need a socket first ?!

Ich spreche kein deutsch.

eBay US

I need also a socket.

This and...