OpenWrt 18.06.1 Service Release

Also, that wiki needs re writting since most of those kmods in steps 1,7 are not required anymore. The new release (18.06) for my hardware anyway are using dwc2 or dwc3 (builtin) which seem to be a better unified kmod for usb2/3

There are already quick installation guides for various use cases. The USB installation guide is supposed to be extensive and help those who are still having problems after following those.

1 Like

Hi lleachii

Now it worked, Problem fixed on my WRT32X, booted up in my other partition, where I still had OpenWRT 17.05, from there, did flash and it worked:

OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)

Kernel Version 4.14.63

Best greetings everybody =D


Do you guys know what the current packages are required to build a full buildbot , I think from must be missing some packages. I am building on a Docker Debian Stable.

I have a list eg:

asciidoc bash bc time bcc bin86 binutils build-essential bzip2 cmake curl default-jdk fastjar file flex gawk gcc genisoimage gettext git git-core intltool jikespg libboost-dev libgtk2.0-dev libncurses5-dev libssl-dev libusb-dev libxml-parser-perl make mc mercurial nano ncdu patch perl-modules python python-dev quilt rsync ruby sdcc sharutils software-properties-common sshpass subversion sudo unzip util-linux wget xsltproc xz-utils zlib1g-dev g++-multilib swig python3 python3-dev

For example, I can't build hostpad-utils and give it is not a feed, i have no idea which make I could figure out the error would be.

I added only these recently: g++-multilib swig python3 python3-dev but it still does not build what I am needing.

@patrikx3 You already have created a topic for your problem.
Please don't double post.

Ok, sorry, mistake

Upgraded 18.06.1 on wrt1900acs without problem.

WNDR3800s (2 of them) going on strong here

Did manage to upgrade my "Archer C7 V2" , needed to use the Israeli Version, I'm in Europe.

Sysupgrade with the wrong version:

root@OpenWrt:~# sysupgrade -v /tmp/
Image metadata not found
Invalid image, hardware ID mismatch, hw:c7000002 494c0001 image:c7000002 00000001.
Image check 'platform_check_image' failed.

The calculation of the average load seems to be wrong - it goes up and up and ......

tested on Archer C7 v2 and TL-WR1043N v4

If you're logged into LuCI the average load will increase.

How are you viewing average load?
How long did you wait for the measurements to settle?

For example if you just started luci with autorefresh on, the load will start increasing. But it will settle since the average is calculated over a period of time

I view it just in the overwiew or in the realtime graphs - the 1 minute values goes up to 2.0 and then settles around 1.0. I just don't remember such high values in the past.

Probably just luci doing background work.
If you want a cleaner measurement turnoff autorefresh wait 15 minutes then do a manual refresh on your browser.


Use SSH and run top or htop if you have it installed

1 Like

With top the average 1 minute load is around 0.03 - so the higher values are caused by Luci.Thanks for the clarification.


Installed ok on TP-Link TL-WR741ND. Free flash remained unchanged at a slim 84k with a few additional small scripts.

The TP-Link TL-WR741ND is version 4.22.

Also reflashed my TP-Link TL-WDR4300 with no problems. Available flash memory unchanged from 18.06.00

Hi I installed to Archer C7 v2, and I have PPPOE problems, cannot connect to ISP: simultaneous more open sessions issue.

PPTP client in 18.06.1 doesn't work for more than a few minutes on BT HH5a connecting to VPN provider. When the VPN connection suddenly stops working, the system log is overflowing with "Protocol-Reject for unsupported protocol" messages. Same behaviour with two different VPN providers.
I've opened a bug report.
PPTP client in 17.01.4 doesn't suffer from this behaviour on HH5a.

Using updated PPTP client setup instructions in wiki.