OpenWrt 18.06.01 bridging problem

I tried mentioned OWrt on two devices: OrangePiZero and A5V11 router.
In both cases there is a problem with bridging interfaces, there is nothing in LUCI shown!?

Also, "improving" to this version the "user changed" memory from 4MB to 8MB is destroyed when I do reset of the router pressing button - no problem with ChaosCalmer.

Do you really expect to obtain any help to a statement as vague as "there is a problem with bridging"?

1 Like

I do not expect help, I simply gave up 18.06.1 as it is total fail

I write clearly: there is nothing in LUCI shown

where there should be list of all interfaces to choose for bridging there is NOTHING! just grey line from left to right

I am happy to statr to use ChaosCalmer in the past

Another PROBLEM is that stupid confirmation if I change some settings in network over LUCI, if you do not confirm it AFTER 30 seconds then it reverts back? What for???

You have understood it wrong. The feature tries to prevent accidental soft-bricks due to invalid network/firewall config. There are surprisingly many cases where the user lock himself out of the router by doing a config change that causes the router to be inaccessible.

  • If you do a "normal" change, and the connectivity from browser to router stays alive, no confirmation is needed.
  • If you do a connection-breaking change, e.g. change router's IP address, then the router loses connectivity with the browser and it will revert back to the old settings after 30 seconds. When connectivity then returns (with the old settings), you are then offered the possibility to apply the changes in any case, regardless that the connectivity breaks.
1 Like

Can you mention the browser you used?

hnyman - you can confirm bad setting even after 30 seconds, this does not save anything just makes me upset

jow- i used Mozilla but it is not browser, everything else seems to be OK, I did not notice anything else wrong in LUCI (I mean "noticed" I could overlooked...)

I am asking because the dropdown that is supposed to appear instead of the grey line uses some CSS and JavaScript features which might not work with older browser versions. What version of Mozilla is it excactly?

Sometimes the issue can also be simply an older cached JavaScript file, in this case clearing the browser cache or hitting reload a few times while holding the shift key will also work.

Also some browser extensions like NoScript / uMatrix.

1 Like

mbo20 - no, settings unclicked

jow- is it different now from what was used in ChaosCalmer? because CC works normally....

I mean my broswer perfectly understands CC LUCI

I think the best is to try it...

Yes, that specific ui code is completely different.

1 Like

is this specific code used somehere else in LUCI for version 18.06.1 ?

graphically it does not look different at all

Why was this changed? It was working nice....

Yes, in various places. Firewall rule details, interface settings, SSH server settings and a few more I can't remember right now.

Anyhow, can you mention the specific version of your Mozilla browser so that I can try to isolate and fix the problem?

jow- I work abroad I do not know when I will be with "my" PC I used..

anyway, all you mention I have not noticed any problem... I think problem is different and not a browser

one more info: I generated images to suit me, I am not aware of something that would be missing, if I have "luci" in options it should take everything it need? I tried to compare "software" I have in CC but it is difficult to estimate what it could be

jow - I just remembered I also tried it at work and here I have Mozilla browser 47.0.1

I would bet my neck it is not a browser problem... please keep me informed (if I should generate new images or not)

Okay, I tested with Firefox 47 and it worked okay. To clarify it should look like this:

If you still have the "grey line problem", please try hitting F12 when on the page, switch to the console tab and look for any error messages, maybe reload the page once or twice while the debugger is open to see if new error messages appear.

1 Like

jow - now I am a bit confused.. vgaetera writes something I do not understand

was it a problem in LUCI and I need to regenerate new images?
or is it really a browser problem?

where is that JavaScript and what I should do about it? just to hit F12?

That's relevant only for those who use browser extensions blocking JavaScript, such as NoScript, uMatrix, etc.

In your case the fastest way to verify the problem is to check it from another browser.