OpenWrt 18.06.0 release

Is /etc/config/fstab being ignored ? I tried to move the rootfs to an external device as per previous releases, and it seems not to use /etc/config/fstab - unless this is down to boot/load order?

Make sure to remove any existing .extroot-uuid files from your external disk. Also check logread / dmesg for extroot / block / mount messages.

Thanks for all the hard work

Installed on my TP-Link WDR-4300. No problems to report. I think the admin pages load a bit slower then they did on 17.x, but nothing alarming.

I noticed a slight lag on mine as well.

Given the "freshness" of 18.06.0 is there any chance the kernel (where needed - 4.9+) is going to get patched and maybe 18.06.01 released?

Kernel patch:

Looking at the timestamp of the OpenWRT 18.06.0 builds - Tue Jul 31 2018 and at the date the kernel patch was committed - 23 Jul 2018, maybe OpenWRT 18.06.0 is already patched. Have no idea how to check that (where to find the exact kernel sources used for the build) and consider that this can be only confirmed by the OpenWRT dev team.

1 Like

Congrats on what is really a HUGE achievement!

It's seems to be fixed in kernel 4.9.116 and 4.14.59.
18.06.0 was released with 4.9.111 and 4.14.54.

There was another commit for 4.9 today which will be in kernel 4.9.119:

This commit is already in 4.14:

I think I've found work arounds for my issues with my Western Digital green HDD.

[   11.061472] usb-storage 1-1:1.0: Quirks match for vid 152d pid 2329: 8020

If I use hdparm -S 48 /dev/sda the drive disappears. This hasn't been a problem with OpenWRT backfire or chaos calmer.

[ 1869.512819] scsi host0: usb-storage 1-1:1.0
[ 1870.617631] scsi 0:0:0:0: Direct-Access     WDC WD10 EARS-00MVWB0          PQ
: 0 ANSI: 2 CCS
[ 1870.629754] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/93
2 GiB)
[ 1870.638794] sd 0:0:0:0: [sda] Write Protect is off
[ 1870.643647] sd 0:0:0:0: [sda] Mode Sense: 28 00 00 00
[ 1870.644391] sd 0:0:0:0: [sda] No Caching mode page found
[ 1870.649841] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 1870.678946]  sda: sda1
[ 1870.688536] sd 0:0:0:0: [sda] Attached SCSI disk
[ 1871.614877] usb 1-1: reset high-speed USB device number 12 using ehci-platfor
[ 1871.764860] usb 1-1: device descriptor read/64, error -71

If I don't mount the drive directly after booting my WR1043ND v1 it disappears with error -71 after a few seconds.
I managed to configure a mount point to avoid inactivity:

ucitrack.@fstab[0].exec='/sbin/block mount'

I don't want to leave the drive spinning all the time it is not in use and I installed hd-idle.
The process command seems to be wrong with -i used twice but at least the drive doesn't disappear as with hdparm and the drive stops spinning after 4 minutes.

  987 root       904 S    /usr/bin/hd-idle -d -i 0 -a sda -i 240

My configuration for hd-idle is:


There have been many changes since OpenWRT 15.05.1 and I wasn't even aware that my WD hdd is a device with quirks. Now hdparm doesn't even work for info like hdparm -I /dev/sda. I have to unplug the power cable from my hdd to make it work again.

I'd be glad about update that avoids the error -71 and makes hdparm usable again but I know there have been thousands of commits since 2015.

It's currently working somehow at least until the next power outage. Thank you.

This seems to work. Thank you. Another issue, on the Buffalo WBMR-HP-G300H when the "non-wildcard" option is turned on, dnsmasq fails to start with this message:

"cannot set --bind-interfaces and --bind-dynamic"

It seems to work fine on the BT HomeHub - so I wonder if there are specific compile options that are slightly different here.

Hello, I have problem with new fw version. I cant get automatically default gateway from my provider, but for older version 17.01.4 all work. if i set static router i get internet but it must works automaticle.
Help me pls

DUPLICATE: Default gateway problem

i have the same problem, did you find a fix?

yeah. There is a another topic in the forum but I don't have the link now. What I did is reboot the router from the luci ui. Then everything works well.

So, if what you have done is power off the router or reset the router with the router hardware. Then you can try to reflash openwrt and reboot it from luci this time. The reason is that something is not written to the nand flash when you power off the router.

ok thanks. i did find the other topic: [Solved] Asus RT-AC58U and OpenWrt 18.06 problem

I upgraded to 18.06.0 on Aug 7th and everything was working well. Then on Aug 11th, I upgraded 3 packages and my networking, particularly wifi, has become noticeably less stable from multiple / all devices. The packages are:

Package: mwlwifi-firmware-88w8864
Version: 2018-06-15-8683de8e-1
Depends: libc, kmod-mwlwifi
Status: install user installed
Architecture: arm_cortex-a9_vfpv3
Installed-Time: 1534013771

Package: libuci
Version: 2018-08-11-4c8b4d6e-1
Depends: libc, libubox
Status: install user installed
Architecture: arm_cortex-a9_vfpv3
Installed-Time: 1534013772

Package: uci
Version: 2018-08-11-4c8b4d6e-1
Depends: libc, libuci
Status: install user installed
Architecture: arm_cortex-a9_vfpv3
Installed-Time: 1534013772

Details of my build are:

Model: Linksys WRT1900AC
Architecture: ARMv7 Processor rev 2 (v7l)
Firmware Version: OpenWrt 18.06.0 r7188-b0b5c64c22 / LuCI openwrt-18.06 branch (git-18.219.52706-a49e4e4)
Kernel Version: 4.14.54

I'm wondering -- has anyone else noticed any issue after such an upgrade to those packages? Also, I have been trying to figure out how to downgrade an individual package, and although I understand there's a --force-downgrade option to opkg, I simply can't FIND the previous version(s) available anywhere.

Any help would be appreciated.

1 Like

Just installed OpenWrt 18.06.0 r7188-b0b5c64c22 on my NETGEAR WNDR4300.
It works fine but I can't find iptables-mod-geoip. That module was available in lede.
Will it be available soon in the repository ?
Perhaps, i can try to compile it but I have to learn more how to find the good way for cross compiling.

Should be available for mips_24kc:

maybe you forgot to opkg update?

18.06.1 appears to being built now (August 16th, 2018) with results appearing under

Things that caught my eye (this is not an official release note) from git log v18.06.0..v18.06.1 include:

  • openssl 1.0.2p
  • kernel: bump kernel 4.9 to version 4.9.120
  • kernel: bump 4.14 to 4.14.62
  • mwlwifi: update to version
  • wpa_supplicant: fix CVE-2018-14526
  • mbedtls: Update to 2.12.0
  • kernel: backport upstream fix for CVE-2018-5390

and a lot more.

1 Like

I dn't forgot 'opkg update' but the link provided here is for lede version .
iptables-mod-geoip is not available for OpenWrt 18.06.0 but exist for OpenWrt 18.06.1.
I shall wait for openwrt-18.06.1-ar71xx-nand-wndr4300-squashfs-sysupgrade.tar not yet available now.
Then I can upgrade to that version.