OpenWrt 18.06.0 release

Ok then, not very knowledgeable with the ImageBuilder, I guess I'll stick with Chaos Calmer, runs rock-solid for almost 2 years now and I don't mind the unresolved KRACK issue as I'm always going through OpenVPN on WiFi (Raspberry Pi as full fledged Linux "router extension").
I'll wait until these so called "GigaBit" routers that have enough space to accommodate 18.06.0 will get cheaper and more powerful (in order to handle PPPoE at least at 500MBit/s) and maybe consider to upgrade my 100Mbit Internet line (useless ATM). Still considering a 30EUR Raspberry Pi as a "router extension" better, more powerful, more flexible than anything a modern router can provide me in terms of usability.

For the Netgear r7500/ r7500v2/ r7800 and d7800 you can only upgrade from 17.01.x to 18.06.x by doing a tftp installation (which loses settings). The NAND partitioning for the kernel had to be changed from 2 MB to 4 MB (and while at it, the rootfs/ overlay has been grown from 19 MB to 96 MB), which can't be done via sysupgrade and requires flashing from the bootloader via tftp.

1 Like

like slh explained, R7800 requires using the TFTP flash to go into 18.06.0 and later.

Advice is found in:

1 Like

@hnyman Thanks for the links, who reads this anyway before flashing? ;- )

I can not find firmware for TP-Link TL-WR703N v1

It is again a 4/32 device. Likely the 18.06 image with LuCI is just too big and can't be built.

Read discussion in e.g. Will there be "OpenWRT 18.06" support for TL-MR3220? (4/32 tiny device)

And also

1 Like

Thx, I have HW mod 64 mb ram and 32 mb flash. Maybe change Id device in fullflash, to exmpl wr802n!?

One improvement on my router (Archer C7 V2.0) since I started testing RC2 is that it seems to have fixed whatever bug was breaking ARP on my network (11 days of uptime with no problems).

With Chaos Calmer and LEDE 17.01.x it would stop working on my home network on a time span ranging from a few hours to a few days (all clients wireless, same SSID for 2.4 and 5 GHz, didn't matter if clients were using the same or different frequencies). Bringing the interfaces up/down didn't fix it, restarting the network service or rebooting would.

After upgrading I'm seeing very, very slow WAN performance. I'm using a Xen setup with the NIC passed through to the OpenWrt VM. The WAN NIC is a RTL8168d/8111d using the r8169 driver.

Performance on the emulated e1000 LAN seems to be fine. Also, I'm not seeing performance issues on 17.01.4.

I think the long-term answer is to get a less terrible NIC on the WAN side, but I'm wondering if anyone else is seeing this or if it is something specific to my configuration.

Yes, I did.
Now I'm embarrassed.

bad news, it's not working properly on WR1043ND v1.

installs ok but then you cannot upgrade or download any package with out of memory errors, here's an example:

root@LEDE:~# opkg list-upgradable
Collected errors:
 * pkg_hash_add_from_file: Failed to open /var/opkg-lists/openwrt_routing: Out of memory.

and i have plenty free memory

root@LEDE:~# free
             total       used       free     shared    buffers     cached
Mem:         27832      20104       7728       1164       1388       4232
-/+ buffers/cache:      14484      13348
Swap:            0          0          0

that is a stock upgrade from 17.05.1 to 18.06, couldn't install anything.

had to downgrade at the end and now i can install and update everything

I used this path:
this image:

It was installed as an upgrade from 17.01.5
My device is hardware version 4.22

Openwrt LUCI Software tab shows:
Free space: 26% ( 84.00 KB ) with 18.06.0

Under 17.01.05 I had 212 KB free space.

LUCI is included. I did not install any additional packages but have scripts loaded in startup and twenty or so lines in scheduled tasks.

Maybe try first flashing 17.01.5 (reset to defaults) then 18.06.0. Could you possibly have a lot of certificates or other configuration items accumulated somewhere?


I installed 18.06.0 on a fresh R7800. Things go well before I restart my router. After the rebooting (I just setup pppoe and wireless), I can no longer connect to my router from a browser. I can still use ssh. After check the config files. I found that /etc/config/rpcd,ucitrack,uhttpd becomes unreadable. But those files do have something in them but they are not text now.

-rw-r--r-- 1 root root 808 Jul 30 16:25 dhcp
-rw------- 1 root root 86 Jul 30 16:28 dropbear
-rw------- 1 root root 2.6K Jul 30 16:35 firewall
-rw------- 1 root root 923 Jul 30 16:36 luci
-rw------- 1 root root 843 Jul 30 16:36 network
-rw------- 1 root root 97 Jul 30 16:25 rpcd
-rw-r--r-- 1 root root 908 Jul 30 16:25 system
-rw-r--r-- 1 root root 0 Jul 30 16:25 ubootenv
-rw-r--r-- 1 root root 807 Jul 30 16:25 ucitrack
-rw------- 1 root root 3.7K Jul 30 16:25 uhttpd
-rw------- 1 root root 821 Jul 30 16:32 wireless

There's a regression to the "option prefix_filter" settings for odhcpd in the release. It was working on RC1, but in this release it is broken. All IPv6 prefixes are advertised despite that filter.

@jow If there a way to report this bug?

4/32 are OK. I use it with MR-3040. The image is smaller than 17.01, because LTO is used on some packages.

Issue can be logged in ; please provide the used dhcp and network config

I have also an WR1043ND v1 in use.
Usually I have an extroot (+swap) configuration, and there is everything working.
Because of your post I disabled extroot/swap, and I was still able to load opkg softlist and to install packages.
Only, in this configuration I have no luci installed.
Memory after installing some packages:

root@sickbox:~# free
             total       used       free     shared    buffers     cached
Mem:         27832      19868       7964        668       2020       5000
-/+ buffers/cache:      12848      14984
Swap:            0          0          0

@Azmuth i have luci installed, no extroot or swap or anything weird other than stock lede install

Thanks for the hints! I was reluctant to upgrade the 15.05.01 running TL-WR741ND v4 directly
to 18.06.0, but followed your advice and used LEDE as an intermediary step. Not sure if it's really needed, might work to directly flash 18.06.0 on it .

Success: TP-Link TL-WR741ND v4

  • TP-Link TL-WR741ND v4 running openwrt-15.05.1-ar71xx-generic-tl-wr741nd-v4-squashfs-factory.bin (280 KB free space)
  • removed the packages libpcap & tcpdump-mini (that I installed) and kept the configuration including a firewall custom script (a few pages of rules)
  • LuCI unable to upgrade directly to openwrt-18.06.0-ar71xx-tiny-tl-wr741nd-v4-squashfs-sysupgrade.bin
  • LuCI - upgrade to lede-17.01.5-ar71xx-generic-tl-wr741nd-v4-squashfs-sysupgrade.bin (280 KB free space)
  • LuCI - upgrade to openwrt-18.06.0-ar71xx-tiny-tl-wr741nd-v4-squashfs-sysupgrade.bin (88 KB free space)
  • everything's dandy! Lost the ability to install the very useful tcpdump, running stable and no apparent speed drop on pppoE - 96-98 Mbps on

Failure: D-Link DIR-300B1

  • D-Link DIR-300B1 running openwrt-15.05.1-ramips-rt305x-dir-300-b1-squashfs-factory.bin (260 KB free space), already "castrated", speed on pppoE won't reach over 30-40Mbps
  • removed libpcap & tcpdump-mini and kept the configuration including a firewall custom script (a few pages of rules)
  • LuCI unable to upgrade directly to openwrt-18.06.0-ramips-rt305x-dir-300-b1-squashfs-sysupgrade.bin
  • LuCI - upgrade to lede-17.01.5-ramips-rt305x-dir-300-b1-squashfs-sysupgrade.bin (280 KB free space), still "castrated" pppoE won't reach over 30-40Mbps
  • LuCI - upgrade to openwrt-18.06.0-ramips-rt305x-dir-300-b1-squashfs-sysupgrade.bin - lost configuration, unable to save anything, Free space: 100% (13.70 MB)

Second try:

  • D-Link DIR-300B1 entering flash recovery mode (reset button pressed - interface at
  • loading lede-17.01.5-ramips-rt305x-dir-300-b1-squashfs-factory.bin - (300 KB free space)
  • applying openwrt-15.05.1 saved configuration, freeze after reboot - worked for a few seconds

Third try:

  • D-Link DIR-300B1 entering flash recovery mode (reset button pressed - interface at
  • loading openwrt-18.06.0-ramips-rt305x-dir-300-b1-squashfs-factory.bin -unable to save anything, Free space: 100% (13.70 MB)

Must be something wrong with the D-Link DIR-300B1 images. It runs solid on DD-WRT latest with pppoE at the "normal" speed of 96-98Mbps.

Thanks for this new release. 18.06 runs great on my WR1043ND v1. Because I installed Luci Material design at first I ran out of RAM quickly. Luckily I could still install a few packages with LuCi or ssh after every reboot. I made my way to usb, vfat and swap support.
But for neewbies it might be easier if you divide the package lists into chunks this 32MB RAM device can handle. On the other hand I'm happy that you haven't dropped the support yet.
Keep up that great work.

(Made a swap-file on an existing vfat filesystem with sudo dd if=/dev/zero of=/media/sdb1/swap count=256k and sudo mkswap /media/sdb1/swap on my desktop pc. This is much easier than creating new partition tables on SD cards.)