OpenVPN working, but not quite right

I have a router flashed with LEDE v17.01.4 and installed OpenVPN. It seems to be setup right and connects fine, but a certain popular streaming service can still make out my geo-location (I'm in the UK connecting to a US VPN).

Funny thing is, I also setup a VPN L2TP on my computer, which also connects fine - but this way the streaming service work seamlessly with exactly the same credentials, as if I were in the US.

The one difference I've noticed between the two ways of connecting is, when I use the router's OpenVPN to connect, DNS servers remain on Google's default (as checked with Whereas when I use L2TP on the laptop, DNS changes to my VPN provider servers - as it should. Perhaps an important clue here.

I would very much prefer to connect at router level. It looks like the OpenVPN on the router falls short compared to the built-in connection service on the mac OS X, but where?

Any ideas?

Compare results for OpenVPN and L2TP connections:

I did both tests.

OpenVPN - completely stealth, except IP/browser difference in time zones
L2TP - IP/browser difference in time zones, but also tested positive for VPN fingerprint
No DNS leaks either way.

If anything, the OpenVPN should be the one working right but it's the other way around.

The IPleak test again shows google DNS for OpenVPN, and VyprVPN DNS (my VPN provider) for L2TP.

It's possible to ignore pushed DNS:

pull-filter ignore "dhcp-option DNS"

However, I suspect they detect VPN by VPN-server IP-address:

It could also be IPv6 or WebRTC.

everybody uses now vpn over vpn , of course this is short live solution until "they" figure how to block this, and this works only on devices without gps

Really sorry for the bump, but I wanted to reply to this so anyone searching for a solution here can find one, as I couldn't find the answer to this problem anywhere else.

I was experiencing the exact same problem as OP - running OpenVPN on router flashed with OpenWrt, everything looked good with the VPN as it showed my location in the desired country, but streaming services still knew I wasn't actually there and I was blocked as if I was in my home country.

The results showed I was located in the UK (great) but my DNS servers were all based in Germany (not great). This was an important clue as @miller suggested!

Thankfully the solution was quite simple. All the devices connected to the router just need to update their DNS server information to match the DNS servers hosted by the VPN provider. I'm sure there's a way to do this at router level but I couldn't make anything work. I use Nord VPN so found their DNS servers on their website, and replaced the DNS servers for that network on my Apple TV and iPhone with the ones from Nord, instead of the default

I can connect at router level and everything that connects through that router gets put behind the VPN as desired, streaming services work perfectly.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.