Openvpn won't start

Hi guys,

I had my router up and running for a while.

However, I had to restore the router from a backup.

Now, everything is okay besides the OpenVPN.

It was not installed, I installed it and my previous connection client to server was there. Great.

However, It won't start.

I cannot find the logs on /var/log/

I was able to find something on logread:

Sat Sep 28 16:24:56 2019 daemon.err uhttpd[1089]: sh: /etc/init.d/openvpn: not found

And in /etc/init.d/ was missing the openvpn daemon.

I am stuck now as I cannot find how to repair this.


opkg update
opkg --force-reinstall install openvpn-openssl
1 Like

Great vgaetera. Thanks it worked! updating the openvpn-openssl.

However now I am facing another issue... VPN Bypass won't start.
Also, If I tried to amend the rules I had the following error:

Failed to execute cbi dispatcher target for entry '/admin/services/vpnbypass'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/vpnbypass.lua:75: attempt to call field 'restart' (a nil value)
stack traceback:
/usr/lib/lua/luci/model/cbi/vpnbypass.lua:75: in function '?'
/usr/lib/lua/luci/cbi.lua:226: in function '_run_hooks'
/usr/lib/lua/luci/cbi.lua:403: in function 'parse'
/usr/lib/lua/luci/dispatcher.lua:853: in function </usr/lib/lua/luci/dispatcher.lua:832>

I tried to do opkg --force-reinstall install vpnbypa
ss luci-app-vpnbypass

Did not work

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.