OpenVPN - static IP configuration help?

Hello - would greatly appreciate a little assistance or maybe point me in the right direction ...

Here is my setup:

  • Netgear Nighthawk X4S R7800 - default Netgear firmware running as primary router
  • Netgear Nighthawk X4S R7800 - OpenWrt 18.06.5 r7897-9d401013fc / LuCI openwrt-18.06 branch (git-19.309.48729-bc17ef6) - running as my vpn router.
  • OpenVPN-openssl package v.2.4.5-4.2 installed

I am physically located outside the US - currently using NordVPN' service - standard config file for server in US - connecting via DHCP. This configuration is working fine. Unfortunately, some services i usually connect to are now detecting that i am using a vpn/proxy and blocking access. After - a little research - decided to try switching to a dedicated IP with NordVPN. I have been assigned a static IP and they have instructed me to connect to a specific server - i have download the config - *ovpn file for that server and copied it to the router and updated the openvpn config file. In Luci - under OpenVPN - services - the new server is present. However, unable to get it to start. Checking the logs - initially was getting error messages - "unable to open configuration file". I seemed to have been able move past that - now getting ....

"neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Auth Username:'. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.
Wed Feb 12 18:40:24 2020 daemon.notice openvpn(nordvpn_united_states29[9711]: Exiting due to fatal error"

Looks like a configuration issue ... haven't been able to find any documentation on setting it up with a static IP.

Thanks for your help!

This has nothing to do with being static: your VPN client needs your username and password on the VPN server, and cannot obtain them. You must create a config file containing the username and password (each one on a separate line), and reference that file from the VPN configuration.

1 Like

Actually - already have the auth file with username and password. But - your reply prompted me to go back and re-compare the static server config file (.ovpn) with one of the server config files that is working and i don't know how i missed before - but in the file there is a parameter - auth-user-pass. The new static server config file was missing the path to the config file with the username/password. Once i plugged in the path and re-tried it - it worked. I am connected but did not receive the IP that was assigned - the one i received is on the same subnet however. I tested a couple of the services i am having issues with - still recognizes that i am on a vpn and blocking. I have have a ticket open with Nordvpn support - waiting on their response. Thanks again!

PS - i will try disconnecting and reconnecting to see if i am assigned the same IP.

1 Like

I do not think NordVPN can solve the issue you are experiencing: even they assign you a fixed IP address, they will assign you an IP address from the pool that was assigned to them, and probably all IP addresses belonging to any major VPN provider is now on a blacklist.

Yeah - it was worth a try. Sling TV works fine across my Roku's - was giving Hulu a try - blocked on the Roku's - however works on my laptop connected to same VPN. Amazon Prime Video also detects that i'm on a VPN.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.