OpenVPN server config comp-lzo weirdness

The weirdness is about setting comp-lzo to 'no' doing nothing.

The server config is

config openvpn 'server'
option dev 'tun'
option comp_lzo 'no'
option dh '/etc/openvpn/dh.pem'
option keepalive '10 60'
option key '/etc/openvpn/server.key'
option cert '/etc/openvpn/server.crt'
option verb '3'
option ca '/etc/openvpn/ca.crt'
option server '10.0.100.0 255.255.255.0'
option port '35138'
option mode 'server'
option ifconfig_pool_persist '/etc/openvpn/ipp.txt 600'
list push 'redirect-gateway def1 bypass-dhcp'
list push 'dhcp-option DNS 68.94.156.8'
list push 'dhcp-option DNS 8.8.8.8'
option tls_auth '/etc/openvpn/ta.key 0'
option cipher 'AES-256-GCM'
option persist_tun '1'
option persist_key '1'
option status '/var/run/openvpn.status 5'
option proto 'udp'
option enabled '1'
option log_append '/var/log/openvpn.log'
option topology 'subnet'

If I don't have comp-lzo in the client config, then it will connect, but the connection won't transmit any data and the server log warns that

WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'

So the fix is easy, just add comp-lzo to the client config. However, I thought I set comp-lzo to 'no' clearly in the server config.

Openvpn version 2.5.8-3 and the router is running openwrt 23.05.2

The option should be:
option compress 'lzo'
Therefore if you want to disable it, you need to remove the line.

1 Like

There is no
option compress 'lzo'
in the config though, so I don't see how to remove.

The config for my server is mostly generated by LUCI, and the comp_lzo part is generated by this box:

Thus I guess LUCI needs to be changed to output the correct config?

Maybe something changed in the 23.05 version, and since I am still on an older version I won't be much of assistance.

Maybe its related to this issue: