OpenVPN on Luci

I've tried to set up a new OpenVPN using LUCI, but when I add a new connection I get this:

/usr/lib/lua/luci/dispatcher.lua:460: Failed to execute cbi dispatcher target for entry '/admin/services/openvpn'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/openvpn.lua:64: bad argument #4 to 'set' (string expected, got boolean)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:460: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:141: in function </usr/lib/lua/luci/dispatcher.lua:140>

Is there any package I'm missing? Anything else?


ubus call system board
	"kernel": "4.14.131",
	"hostname": "IPS-231-0000",
	"system": "Ralink RT5350 id:1 rev:3",
	"model": "WIZnet WizFi630A",
	"board_name": "wizfi630a",
	"release": {
		"distribution": "OpenWrt",
		"version": "18.06.4",
		"revision": "r7808-ef686b7292",
		"target": "ramips\/rt305x",
		"description": "OpenWrt 18.06.4 r7808-ef686b7292"

Solved. flock was missing from the system. Sorry for the noise.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.