Openvpn management interface

Hello guys, wanted to ask if management interface of openvpn is not supported in openwrt?
Because i have openvpn server and when i try to enable management interface logread shows errors:

Mon Aug 23 11:34:01 2021 daemon.err openvpn(server)[15976]: Options error: Unrecognized option or missing or extra parameter(s) in /etc/openvpn/server.conf:18: management (2.5.3)
Mon Aug 23 11:34:01 2021 daemon.warn openvpn(server)[15976]: Use --help for more information.

although, when i load this configuration on ubuntu, it works.

my server.conf:

user nobody
group nogroup
dev tun
port 1194
proto udp
topology subnet
keepalive 10 60
push "dhcp-option DNS"
push "dhcp-option DOMAIN lan"
push "redirect-gateway def1"
push "persist-tun"
push "persist-key"
**management 7505 **

Tried all variants like:
management 7505
management localhost 7505
management 7505 "/etc/config/openvpn-psw"

also tried to add management in openvpn uci file:

config openvpn 'server'                      
        option enabled '1'                  
        **option management ' 7505 /etc/config/openvpn-psw'**
        option config '/etc/openvpn/server.conf'
	bool "Enable management server support"
	default n

You'd have to build from source and toggle that setting.

1 Like

Hi, can you explain more?
I need to download wolfssl package and then put this command in openvpn config?

I found this:

As mentioned before, OPENVPN_*_ENABLE_MANAGEMENT is a build-time setting, not a runtime selection. If you want to use it, you need to build OpenWrt (respectively at least openvpn via the SDK) from source, with changed defaults.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.