OpenVPN - localhost network unreachable

Hi, I have a small ARM based router GL-A1300. I have a software that is (should be) used as a proxy for OpenVPN and listens on 127.0.0.1:8000.

I open first terminal, ssh to the router, run the software and watch the output.
Then I open another terminal, ssh to the same router, run curl 127.0.0.1:8000, and I can see the output on my application. This means curl can communicate with my proxy software.

Now the problem. I run OpenVPN client, which should connect to 127.0.0.1:8000 (because in OVPN config it has command remote 127.0.0.0 8000).

However, it does not connect to this port on localhost, because:

  • I see no output from my proxy software
  • OpenVPN logs say: daemon.err ovpnclient[29327]: TCP: connect to [AF_INET]127.0.0.0:8000 failed: Network unreachable.

I suspect this is some kind of pa problem with firewall, but I don't know how to solve it. Any idea?

Try 127.0.0.1 instead.

1 Like

Oh... my bad! I had a typo. Now it works!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.