OpenVPN install problems on Mikrotik RB750r2

I recently installed LEDE on my RB750r2: https://wiki.openwrt.org/toh/mikrotik/rb750_r2
I tried following the OpenVPN client guide: https://lede-project.org/docs/howto/openvpn.client

But for installing the openvpn-openssl package, I get this error:
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-openssl:
* kernel (= 4.4.83-1-872cf3078c5b522d2892f840f6eaa04a) *
* opkg_install_cmd: Cannot install package openvpn-openssl.

From other posts I read, I should upgrade to the latest LEDE build, but it's not clear to me if that's possibleRB750r2 since I had to install a snapshot to begin with. Please help.

Install a current snapshot and run opkg install for your packages right away.

When you install a snapshot image, it becomes incompatible kernel-incompatible with some packages as soon as the snapshot with the new kernel/new kernel fingerprint is published.

So you're saying go back and re-install my current snapshot, then immediately try to install the packages I need? I'll give that a shot. Thanks.

I'm a little confused by this. Are you saying to re-install with the same snapshot I currently have? And if a more recent snapshot hasn't been released, am I out of luck?

You need to install the latest snapshot. If you are already on the latest snapshot, then reinstalling won't help you. Sometimes the kernel version in the snapshot and the kernel version for which packages were compiled are out of sync for a short period of time due to delays in the build process. Simply wait for tomorrow's snapshot and try again with that one.

Have you considered installing the release (stable) build rather than the snapshot (development) build?

It's not clear to me if there is a more recent snapshot available, and the stable build may not have the LAN ports working. The build I'm on is LEDE Reboot SNAPSHOT r4696-df3295f and I've been following this guide:
https://wiki.openwrt.org/toh/mikrotik/rb750_r2

The snaphots are produced very frequently -- the latest version for your router was built earlier today. Think of them as developmental "nightly builds". Looks like you need to use a snapshot though for LAN port support on your Mikrotik model:

https://downloads.lede-project.org/snapshots/targets/ar71xx/mikrotik/

That worked. Thank you!