OpenVPN Errors on x86

I am trying to setup OpenVPN on my x86 box running 18.06.2 (squashfs custom build) but I am running into the following error when I try to start the OpenVPN server:
Tue Mar 26 21:48:29 2019 daemon.err openvpn(sample_server)[17236]: Options error: Unrecognized option or missing or extra parameter(s) in openvpn-sample_server.conf:7: ifconfig-pool-persist (2.4.5)

I tried removing the ifconfig-pool-persist from the config and the error switches to this:
Tue Mar 26 21:48:30 2019 daemon.err openvpn(sample_server)[17258]: Options error: Unrecognized option or missing or extra parameter(s) in openvpn-sample_server.conf:11: server (2.4.5)

I've also tried using my existing config file from my working OpenVPN server, but it throws the same errors.

These are pretty basic config options, I can't seem to figure out why it's not recognizing them.

I set the following options in my .config file to include OpenVPN in the build and got no errors during the build process.


My /etc/config/openvpn file looks like this:

config openvpn 'sample_server'
        option port '1194'
        option proto 'udp'
        option dev 'tun'
        option ca '/mnt/sda3/openvpn/ca.crt'
        option cert '/mnt/sda3/openvpn/myfile.crt'
        option key '/mnt/sda3/openvpn/myfile.key'
        option dh '/mnt/sda3/openvpn/dh.pem'
        option server ''
        option keepalive '10 120'
        option persist_key '1'
        option persist_tun '1'
        option user 'nobody'
        option status '/tmp/openvpn-status.log'
        option verb '3'
        option enabled '1'

Any suggestions would be appreciated. Thanks!


This suggests line 11+7 are an issue.... Are you sure there are no other .conf files in /etc/openvpn/?

Those errors were from 2 different config files.

The error that references line 7 was from an earlier config file that had both ifconfig-pool-persist (line 7) and server (line 12) options in it.

The error that references line 11 was from the posted config file that had ifconfig-pool-persist removed and only the server (line 11) option in it.

/etc/openvpn is empty.

Then that is indicative of a syntax error....

Take a close look at every character.......

Why don't you follow the guide:

Thanks for the suggestions, but I was able to resolve the issue by doing a make clean on my build environment and rebuilding.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.