Openvpn error 6 in

Hello everyone. Since last two days I'm getting this error:

Wed Jan 19 18:40:59 2022 kernel: [ 3239.111476] Code: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0f b6 0e 84 c9 74 31 48 83 c7 01 48 83 c2 01 48 83 c6 01 <88> 4f ff 48 39 da 75 e5 c6 07 00 48 89 f7 ff 15 31 2f 13 00 48 01
Wed Jan 19 18:41:05 2022 kernel: [ 3244.134645] openvpn[14799]: segfault at 7f6b3ace2267 ip 00007f6b3ac58013 sp 00007ffd80e83aa8 error 7 in[7f6b3ab47000+197000]

OpenVPN is not working and it's impossible to use NordVPN.
What happened? Frankly speaking I have no idea. My configuration was not changed since last two months. I've been updating packages every few days, nothing more.

I'm running OpenWRT on PC as a router (Hewlett-Packard HP RP5 Retail System Model 5810).

I've tried reainstalling openvpn and libcrypto packages and restore configuration from backup but I'm still getting this error.

Thank you for any assistance.

In my experience segfaults are a general category of errors.
So you'll want to explore the environment of the device.

I am curious:

  • what version of openvpn do you have installed?
  • can you invoke openvpn manually from the console, logged in as the appropriate user?
  • what is the output of uname -a?
  • what is the output of ldd $(which openvpn)?

Thank you for your reply.

  1. My Openwrt version is 21.02.0, r16279-5cc0535800,
  2. When I'm trying to invoke openvpn I'm getting "Segmentation fault" message,
  3. uname - a => Linux OpenWrt 5.4.142 #0 SMP date x86_64 GNU/Linux
  4. I'm sorry but I don't know how to call this properly :frowning:

Sure thing!
One thing to note is your openwrt is not the latest. That may contribute here and you may consider updating.

So that tells us something may be broken with the openvpn installation.

As to #4, it may not be entirely necessary.
But to do so you'll want to:

  1. login as a user using ssh to the openwrt device
  2. from a terminal, execute that command

From a root terminal on my box, I ran a similar command and see:

root@openwrt:~# ldd $(which ls)
	/lib/ (0x77dce000) => /lib/ (0x77daa000) => /lib/ (0x77dce000)

Hello, sorry for my slow response but because of provate stuff I wasn't able to reply.

#4 gave me this

 root@OpenWrt:~# ldd $(which ls)
         /lib/ (0x7f59222fb000) => /lib/ (0x7f59222e7000) => /lib/ (0x7f59222fb000)

Moreover I tried to remove and install openvpn-ssl package and remove openvpn configuration but it gave me the same result.

Is there any safe way to upgrade openwrt to the newest firmware without loosing basic configuration like card1 = lan card2 = wan (bacause openwrt runs on PC not real router so I would not want to broke my router again).

As a general rule, do not use opkg upgrade. Unlike a desktop distribution, OpenWrt is not designed or tested to support that, and it will almost certainly break things. To upgrade, replace the whole OS with the newest version.

Your network settings will be saved when upgrading to a new version. All extra packages will need to be reinstalled, but their config files should be kept. I like to make a directory /etc/config/vpnfiles to save files related to a VPN service (their .ovpn file, certificates, and keys). Everything under /etc/config is preserved during an upgrade.

1 Like

I've done that once and it ended bad. I mean I was forced to configure my PC from the very beginning because I lost my interface configuration so I could not to connect to my PC from other devices anymore.

I'm upgrading packages via Luci. Is it wrong?

Yes that is why OpenVPN broke.

If you're running OpenWrt bare metal on x86 hardware, the numbering of the ports may change between kernel versions, and you'd have to change the config accordingly. That is unlikely going from 21.02.0 to 21.02.2 though.

Also your Ethernet ports could temporarily stop working if they require kmods that are not in the release build (though it looks like that won't be a problem here since it is using relatively new Intel chips).


Oh! I get it now. So the only solution is to just upgrade to the newest firmware and leave it till next upgrade. Sounds bad :frowning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.