OpenVPN configuration

Please remember - you don't have a lot of space to work with:

As @mk24 pointed out, the TL-WR940 has limited resources. Even if you manage to get the packages you need installed on the limited FLA space, the device (and you) will have hard time running them due to its limited RAM and CPU power.

You would hopefully get better results if you would do that on the TL-WR1043N--not that it's the prefect device for the job but it's at least better.

Understood - and looks like the initial configuration will be via cli - but would be nice to have the gui available for future monitoring etc. i originally had a Linksys WRT-300N running the Tomato firmware - but started having issues with the vpn provider - switched to a new vpn provider and could not get it to work correctly - unable to resolve DNS - no matter what i tired - even stumped the vpn provider support - tried installing the WRT-DD firmware on it - but the image for it would only support older vpn protocols which are no longer supported by vpn provider. Went out and picked up the TP-Links yesterday - the choices and availability of Wifi routers here is very limited - for a better router will have to wait for next trip back to the states. In the meantime - i'll try to see if i can get this setup at least functioning. Thanks for your help!

The WR1043v5, having 16/64 memory, should be (barely) suitable. Either run everything on that, or swap the roles of the two that you have.

Yeah - when i picked them up yesterday - i did a quick check on the WRT-DD database in the store - looked like both were supported. When i got home and checked the revision - and checked the database again - found neither hardware revision on each router was supported by WRT-DD. After some research - found the image for the 940N on the OpenWrt site. These were the best available in the store. Ok - might have to re-think this.

4/32 devices are EOLed after 2019

I can't recommend anything less than 16 MB of flash and 128 MB of RAM for a new purchase at this time. There are some great devices that meet those specs starting at around US$20, with the field opening up quite a bit at around US$40.


Looks like OpenWRT supports the LInksys WRT300N - it was working fine before started having vpn provider issues. Will try flashing it with the OpenWRT image. So the OpenWRT learning curve at least is not for nothing.

Yes I'd flash the WR940 back to stock and return it to the store, if they will give your money back. It's really not useful for OpenWrt unless you hack it with larger memory chips.


Thanks for the replies - probably saved me a lot time and aggravation with the 940N. Will give the WRT300N a shot with OpenWRT - and report back with status.


There is no such thing.

  • This project is called OpenWrt
  • Another project, named DD-WRT, is completely unrelated

Just to make sure you have the correct link to search hardware:

BTW, @flyinraptr, welcome to the community!

Take a look at the two infoboxes at the top of the page:

If you want to buy a new device, please take a look at

1 Like

Thanks - typo - meant DD-WRT.

1 Like

Thanks - the Linksys WRT-300N i have is v1.0. OpenVPN was working on it with the Tomato firmware - thinking worth a shot to see if it will run with OpenWRT on it.

Just checked supported devices looks like only WRT-300N V1.1 is supported. So much for that idea.

BTW, you only need to use one post to reply, as we can all see.

TP-Link TL-WR1043ND v5 is supported.

Update - bricked the Linksys WRT-300N. Tried installing OpenVPN on the TL-940N - got message not enough file system space. I have flashed the OpenWRT firmware onto the TL-1043ND successfully. I found a great tutorial written by an OpenWRT community member on the NordVPN site. I am following the doc - have successfully installed OpenVPN - have copied the opvn config file and made appropriate changes. In the tutorial - it talks about making openvpn start automatically via - "/etc/init.d openvpn enable". Struggling with making this happen - not sure what the underlying OS version is?

Have you installed the OpenVPN packages yet? They should have installed the start-up script.


ls -l /etc/init.d/

show -- ah, wait -- actually, don't wait, but look at the output of that command to confirm that openvpn is there.

Then the command should probably be

/etc/init.d/openvpn enable

Yes - successfully installed openvpn packages - it also shows up in Luci now. Configuring via putty - when i do a ls in the /etc/init.d folder - i see only "openvpn" - i'm not clear on how to modify it to "openvpn enable"?

btw - keep getting hit with "you have reached maximum number of replies on first day" This is officially day 2. LOL

1 Like

You aren't modifying it, but rather running it

/etc/init.d/openvpn enable
# ^- executable     ^- argument to executable