OpenVPN configuration problem


i have difficulties configuring OpenVPN. I was already asking in another thread but think like this i can reach more people and don't interfere with the other thread.

Here my Setup:

I'm running LEDE on an Linksys EA9500. Ethernet and wireless are up and running. The EA9500 has IP and is running connected via WAN port behind my ISPs obligatory cablemodem router combo, which has IP
Everything is working fine. i have Internet Access wired and wireless on both routers. So I configured OpenVPN according to NordVPNs tutorial:

After I enable/start the created OpenVPN i don't have access to the internet from the EA9500 anymore, neither wired nor wireless.

The only difference to the created configuration files on my system compared to the sugested ones in the NordVPN tutorial is in /etc/config/network, where it should say after the configuration:

config interface 'wan'
        option ifname 'eth0.2'
        option force_link '1'
        option proto 'dhcp'
        option peerdns '0'
        list dns ''
        list dns '' 

and it says:

config interface 'wan'
        option type 'bridge'
        option ifname 'wan eth2.102'
        option proto 'dhcp'
        option peerdns '0'
        list dns ''
        list dns '' 

Obviously option type is additional, option ifname is different and option force_link '1' is missing after the uci commands. I followed the instructions exactly, but the result in the config file is different.
Things i tried to test:
Running NordVPNs PC App from a PC connected via ethernet to ISPs cablemodem router and the same from a notebook connected wireless and in a seperate test connected wired, wireless disabled to EA 9500.
All Options are working, so passthrough should be not the problem.

Can somebody explain me why and perhaps what to do to get it running?


Yes, only 3 last strings are appended, so previous could differ. Internet is absent completely, so you can't even ping from router?

Thx for your remark. I investigated further: Indeed, i can ping any IP but i can't ping URLs. I even can access sites directly via the respective IP. So it seems to be DNS related.
One more thing i noticed is that in the OpenVPN profile i created in OpennWRT port 1194 is mentioned, although the imported configuration file is a file for port 443 tcp...

Again, im thankful for every input and idea to test out the problem.

Try a fixed DNS configuration on your client.

1194 is the OpenVPN standard port. But NordVPN may use another (tcp 443 for example...)

It is interesting to me that NordVPN wants you to use those DNS entires for the WAN of your router -- I would think that this would be better handled by including these DNS options in the OpenVPN config file itself so that the clients running through the tunnel use those specific DNS servers.

I'd recommend removing the DNS related lines as a first step for troubleshooting. You could use the DHCP supplied DNS servers (likely from your ISP or try another public option lie (Google's DNS). Try that way and see what happens.

Other possible issues -- what is DNS address that machines on your LAN are getting (i.e. DHCP supplied by your router)? Is it the router address, or some other DNS address that was manually specified in the DHCP config?

Ideally, your router should be able to be the DNS server for your LAN (really a forwarder), with the DNS that the router uses corresponding to the NordVPN DNS servers, configured when the tunnel is established (although I'm not sure what the server and client side directives look like -- maybe it isn't included there, but it could be).

Changed the DNS to google and now it seems to work. Will test during the next days and report back.