Opennds with squid proxy loading error

I am using raspberry pi 4 with openwrt.i already installed squid proxy server to well as i need to use opennds captive portal. When I install captive portal I cannot browse the internet(with proxy). i installed squid proxy firstly and after install opennds.if i stop squid in that stage opennds captive portal working correclty.once i disconnect and connect Wi-Fi network(i am using openwrt AP mode) automatically redirect to the captive portal and after the authentication process i can get internet access. But second time i start squid proxy service i don't have to internet access. What can i do to solve this issue. :neutral_face:

Do your clients know they should use the squid proxy ?

This is my university final year project. I am in the testing and configuration stage. I try to use opennds authentication with squid proxy. I can use proxy in with my computer(as client) and smartphone(as client).proxy is working correctly

Does opennds work, when your clients are proxy enabled?

No.Thats the problem :neutral_face:

Then you would need to proxy the traffic sent to opennds, problem is it'll then only see the IP of the proxy, and not the client.
Not sure you can get this to work using this combo/setup.

And ideas @bluewavenet ?

What are the parameters of the assignment/project ?

i am using this to authenticate users. additionally i add squid caching proxy to improve scope is raspberry pi proxy server with secure user data with OpenVPN. This this the category of proof concepts. Do you have any idea to change opennds ip address. If possible to change the ip address, we can add acl rule to the squid to skip authentication process from the squid.I use same gateway ip to all services(opennds,squid,openwrt mangement)I think the problem is blocking authentication process by the i correct?i

You should be able to add a virtual interface, and bind opennds to only that specific IP.

virtual means dummy interface?

Yes, that's right.

thanks lot.after I test it I let you know brother :star_struck:

@uditha @frollic
I have not used squid for many years so I will only be guessing.
As both packages do port redirects I would imagine it will not work if you simply install both.
OpenNDS is a dynamic firewall daemon and always places itself at a higher priority than anything else.
Possibly setting up a guest network for opennds and having all traffic passed on to squid might work.....

What is you definite requirement ? To explicitly use squid AND opennds ?
Or just to use a caching proxy, in combo with a Captive Portal ?
Possible to use squid(proxy)+coova-chilli(Captive Portal), running squid in "transparent" ("intercept") mode. Both on same openwrt-device, to make setup easier.

Hahaha, you always say coova is easier :wink:

When is someone going to rework the code of coovachille so it works on OpenWrt 21xx and later? AFAIK it is still broken.