OpenNDS https protocol


I am new to OpenNDS. In the OpenWRT luci interface, I configured the router to require https. As a result, OpenNDS disables the https protocol. This login interface will not load.

How can I configure OpenNDS to use the HTTPS IP address of my router?

Now I see this interface instead of the login window.

Screen shot says it's using your IP address...

Yes, but I disabled the http connection in openwrt, but openNDS is configured to connect only with http, so I should change that.

How do you think you did that? Do you mean luci?
Luci runs on its own web server. Likewise opennds has its own (and different) web server.

A captive portal cannot run locally on https without generating certificate errors so opennds does not allow local use of https.
If you want the opennds portal on https you must run it on an Internet hosted web server with valid tls certificates.