Opennds: Change default splash to custom splash page

i already add a new file name and chmod that file but still show default splash page, how fix that?

    # ThemeSpec Path
    # Default: None
    # Required when when login_option_enabled is set to '3'
    # Note: /usr/lib/opennds/ is used for login_option_enabled '1'
    # and:  /usr/lib/opennds/ is used for login_option_enabled '2'
    # Sets the ThemeSpec file path to be used when login_option_enabled '3'
    # The ThemeSpec script makes use of lists of custom parameters, custom variables, custom image urls and custom files.
    # and is used to generate the dynamic splash page sequence
    # The ThemeSpec file will normally reside in /usr/lib/opennds/ but can be anywhere accessible to openNDS.
    # The file must be flagged as executable and have the correct shebang for the default shell.
    option themespec_path '/usr/lib/opennds/loginaccess.html'

Restarted opennds?

I do that but still, default splash appeared

hai, I am a newbie to using openwrt, I made the custom splash page for users to access wifi. I using package opennds. I get the error after configuring for the splash page image below, anyone helps me to make my custom splash page

Seems the error's self-explanatory?

Currently, there's nothing wrong with the actual splash page.

You have not stated what you "configured".

It might be better to read the openNDS documentation first:

@Amirakmal260 this is the 2nd time you got the wiki link provided, perhaps you should start
reading it, instead of posting the same question over and over again ?

1 Like

Well, now your other post is merged with this one we can see you posted your config...

The themespec file MUST be an executable complying with the ThemeSpec API.
You are trying to configure it using an html data file, so no wonder it does not work.

If you had read the documentation, you would know this.

To be VERY specific, start by reading this part: