Open VPN Client and MWAN3 Policy

Hi all,

I have Open VPN client running as TUN0.

I like it to use MWAN3 policy wanb_wan.

How do I do this?

Dave

Maybe it would be better to tell us what are you trying to achieve.

1 Like

I have 2 WAN connections and am running MWAN3 to manage them.

1 connection is more reliable that the other, that would be wanB.

I am running Open VPN Client and have linked to a VLAN.

Trying to get the Open VPN Client to use wanB as its primary link and only use wan if wanB fails.

Thanks!

Sounds like you should be using policy wanb_wan then on the default rule.

1 Like

Sorry for not giving the whole story. there are 6 vlans and only 1 of them goes through the VPN Client

Would all the other VLANs then use wanB as primary? Or would I need to write a policy for each of the other vlans to used balanced?

You can have a rule to send that specific vlan to the vpn client and for the rest use the default rule.

I have a rule that send the traffic from the specific vlan to VPN.

I don't know how to do this MWAN3 policy

Am I making any sense?

What is the output of uci export mwan3 ?
Use preformatted text (the </> button) when you paste it.

config rule 'GuestOut'
        option proto 'all'
        option dest_ip '0.0.0.0/0'
        option family 'ipv4'
        option src_ip '10.10.20.0/24'
        option sticky '0'
        option timeout '300'
        option logging '1'
        option use_policy 'wanb_wan'

config rule 'default_rule_v4'
        option family 'ipv4'
        option dest_ip '0.0.0.0/0'
        option proto 'all'
        option sticky '0'
        option use_policy 'wanb_wan'

config globals 'globals'
        option mmx_mask '0x3F00'

config interface 'wan'
        option enabled '1'
        list track_ip '8.8.4.4'
        list track_ip '8.8.8.8'
        list track_ip '208.67.222.222'
        list track_ip '208.67.220.220'
        option family 'ipv4'
        option reliability '2'
        option initial_state 'online'
        option track_method 'ping'
        option count '1'
        option size '56'
        option max_ttl '60'
        option check_quality '0'
        option timeout '4'
        option interval '10'
        option failure_interval '5'
        option recovery_interval '5'
        option down '5'
        option up '5'

config interface 'wanb'
        list track_ip '8.8.4.4'
        list track_ip '8.8.8.8'
        list track_ip '208.67.222.222'
        list track_ip '208.67.220.220'
        option family 'ipv4'
        option reliability '1'
        option enabled '1'
        option initial_state 'online'
        option track_method 'ping'
        option count '1'
        option size '56'
        option max_ttl '60'
        option check_quality '0'
        option timeout '4'
        option interval '10'
        option failure_interval '5'
        option recovery_interval '5'
        option down '5'
        option up '5'

config member 'wan_m1_w3'
        option interface 'wan'
        option metric '1'
        option weight '3'

config member 'wan_m2_w3'
        option interface 'wan'
        option metric '2'
        option weight '3'

config member 'wanb_m1_w2'
        option interface 'wanb'
        option metric '1'
        option weight '2'

config member 'wanb_m2_w2'
        option interface 'wanb'
        option metric '2'
        option weight '2'

config policy 'wan_only'
        list use_member 'wan_m1_w3'

config policy 'wanb_only'
        list use_member 'wanb_m1_w2'

config policy 'balanced'
        list use_member 'wan_m1_w3'
        list use_member 'wanb_m1_w2'

config policy 'wan_wanb'
        list use_member 'wan_m1_w3'
        list use_member 'wanb_m2_w2'

config policy 'wanb_wan'
        list use_member 'wan_m2_w3'
        list use_member 'wanb_m1_w2'

config rule 'vpnOut'
        option proto 'all'
        option sticky '0'
        option ipset 'vpnUSA'
        option use_policy 'wanb_wan'

All your rules use wanb_wan policy, so will prefer wanb over wan.
If you want to send some vlan over the vpn, then you need to assign the vpn to a new member and use it in policies.

Thank you for your help. I shall go try this and hopefully not screw things up :slight_smile: