Only one lan port working on mini-pc

I build a mini-pc to use OpenWRT but only one ethernet port works. I made a diagram. How can I make other ports work?

You need to explain what is wrong with the port. Show the output of ifconfig -a as a start.
No pictures please.

br-lan    Link encap:Ethernet  HWaddr 60:BE:B4:08:A9:B3  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::62be:b4ff:fe08:a9b3/64 Scope:Link
          inet6 addr: fd0d:9586:f845::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1404940 errors:0 dropped:5 overruns:0 frame:0
          TX packets:2339851 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:159619284 (152.2 MiB)  TX bytes:3401658468 (3.1 GiB)

eth0      Link encap:Ethernet  HWaddr 60:BE:B4:08:A9:B3  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1384987 errors:0 dropped:14 overruns:0 frame:0
          TX packets:2173000 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:173157622 (165.1 MiB)  TX bytes:3192971204 (2.9 GiB)
          Memory:80200000-802fffff 

eth1      Link encap:Ethernet  HWaddr 60:BE:B4:08:A9:B4  
          inet6 addr: fe80::62be:b4ff:fe08:a9b4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2337958 errors:0 dropped:0 overruns:0 frame:0
          TX packets:780492 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3418746550 (3.1 GiB)  TX bytes:133262491 (127.0 MiB)
          Memory:80000000-800fffff 

eth2      Link encap:Ethernet  HWaddr 60:BE:B4:08:A9:B5  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:7fe00000-7fefffff 

eth3      Link encap:Ethernet  HWaddr 60:BE:B4:08:A9:B6  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:45 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5473 (5.3 KiB)  TX bytes:19476 (19.0 KiB)
          Memory:7fc00000-7fcfffff 

ifb4eth1  Link encap:Ethernet  HWaddr E2:87:08:7C:E3:02  
          inet6 addr: fe80::e087:8ff:fe7c:e302/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:120338 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120338 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:146732414 (139.9 MiB)  TX bytes:146732414 (139.9 MiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:109282 (106.7 KiB)  TX bytes:109282 (106.7 KiB)

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:10.30.18.12  P-t-P:212.57.0.165  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:2335637 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1404448 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:3366323606 (3.1 GiB)  TX bytes:154931637 (147.7 MiB)

wlan0     Link encap:Ethernet  HWaddr C4:4B:D1:C0:02:FF  
          inet6 addr: fe80::c64b:d1ff:fec0:2ff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24575 errors:0 dropped:0 overruns:0 frame:0
          TX packets:160333 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6381295 (6.0 MiB)  TX bytes:194541307 (185.5 MiB)

wlan1     Link encap:Ethernet  HWaddr C4:4B:D1:C1:02:FF  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I suppose you may need to manually add missing interfaces in Luci Network section. Name them as you want but select the appropriate ethX as an underlaying device. Select protocol DHCP or Static or whatever you need.

2 Likes

Or simply create a bridge for all the LAN ports? On my miniPC, I've reassigned eth0 to wan/wan6 (I just like the numbering better), then created a bridge for all the rest of the ports in /etc/config/network:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        list ports 'eth2'
        list ports 'eth3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.1.3.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0'
        option proto 'dhcpv6'

4 Likes

If you want to use them as additional LAN ports, add eth2 and eth3 to the existing br-lan bridge. This simulates an unmanaged switch where all three of those ports can switch data between each other as well as to the router and the Internet.

On x86 only the first one or two Ethernet ports are configured automatically during the first boot.

Of course eth2 and eth3 could be used for guest networks, etc as well. The results of ifconfig show that the ports have drivers attached, but have not been configured.

1 Like

Normal x86 PC with multiple ports are not the same as those home routers on market, yours doesn't have built-in switch chip to help managing all those ports, so they are simply standalone ethernet ports, and you have to put them into same bridge to simulate the operations of switch (it will consume CPU power since there is no switch chip)

1 Like

It is a small amount of CPU power though, and the x86 will not have a problem switching LAN-LAN traffic at full gigabit speed.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.