Only my PC has no Internet access

Hi, I installed OpenWrt on my Raspberry Pi since yesterday. It was nice how easy it is to set up the own router but I have one problem. All devices connection new to the network connection fine and have internet access but my PC I have done the installation process and the setup with has access to the network but not to the internet. So you can some it up like this:
My setup PC: No Internet access, Access to
All other devices: Internet access, No access to
Did I missed something in the setup or in this forum?
Thanks in advance!

Is your PC configured to be a DHCP client? The most obvious reason it doesn't have internet access is a wrong gateway or DNS server.

Yes, my PC is listed as DHCP. I don't really now why because I have never set this DHCP up and it seems like I can't delete this leases the next 12 h. Maybe the Serup PC gets one automaticly. But is it possible that my other devices use a working DNS Server and only my PC not? And how does it come that my other devices don't have access to the web assistent( On one hand it's good because of security but on the other hand I'm afriad that my PC will lose this access too...

What DNSes does the pc use?

Ah, right. Sorry, I didn't read your problem description well enough.

When all other devices have no access to, I guess they are in another network segment. Could it be possible that you have another router in your network? In that case your PI is on the wrong place in the network. A router is supposed to be placed between the internet and your lan. My guess is the PI has no internet access either? You can test that in Network->Diagnostics.

Thanks for the fast response!
The DNS Server of the PC is PI).

You seem right in the Diagnostics Tool the PI can't reach anything. But how is this possible? The devices where the Internet works are connected to the Pi under the same SSID and the same Encryption. So how can they possible have access but the PI not?

The Error when I try to connect to the PI via Phone for example is "Proxy Server - Connection Filed" and I get redirected to Maybe the PI opened to seperate networks. Is this possible?

Sounds to me all your clients, but your pc, aren't actually using your Pi ..

Please describe your network.

1 Like

Seems like you have two routers and there is an ip conflict.

Sorry for the late answer but I have tried some things.

To describe the overall situation:
I life at an apartment where internet is provided by the landlord. But the "router" didn't work right so I thought I want to learn a little bit more about networking and OpenWrt sounds like a cool thing!
But now I'm not sure if it was even a Router in my room or if the landlord had a network for the building and it was just a repeater. So just you know as much as I know.

My theory right now is following:
A) When I set up an OpwnWrt Pi and enable wifi the devices with internet access aren't connected to the pi but to the network of the building because the pi is just working as an repeater or a wifi station. The interface using is also br-lan so I think the pi just connects the wifi and the lan adapter so all devices joining the wifi of the building. But the first device entering the wifi network(I have set the pi up several times and this seems to be the thing) doesn't connect to the repeater part of the pi but to the pis own network witch has no internet.

B) It's pretty similar to A but there is no such described network of the building but the internet. An argument for this theory is that the ip's and dns server of the connected devices doesn't follow the typical "192.168.." scheme.

I'm not totally sure if this is explained right! There are to solutions:
A) would just be to extend the bridge version but I don't now how to make sure all devices connect to the bridge and not to the useless pi wifi? The devices who are on the pi's wifi habe a ".lan" and the end of there network name.

B) This would be the favorite solution if possible. To give the pi internet access and let all devices connect to the pis own network(the router version). This would give me more control over everything.

Thanks for reading and answering! I now it's a lot of text and maybe everything is wrong but maybe someone can help.

You can't bridge to a public wifi you have to route to it. This is called a routed client.

Create a wan network in the Pi (and name it exactly 'wan') of protocol DHCP client. Attach the Pi radio to it in STA mode. The Pi will hold an IP address from the apartment network and route / NAT itself and your LAN to it. This is built into the default firewall, you don't have to change anything there as long as your new wan network is named exactly 'wan'.

It is important that the WAN network have a different IP subnet than the Pi LAN (192.168.1.X). The wan IP is determined by the owner of that network. If the apartment is also using you need to change the Pi LAN to something different.

Your LAN devices will be wired. I don't think that simultaneous AP and STA is supported on the Pi radio, you would need something with a better wifi chip to do that.

Sorry for the late answer! And thanks for the good description! But I have still a problem. If I only connect the ration0 interface to the wireless network my devices can't connect because it seems like they don't get a IP. But if I connect also the br-lan the problem is as before and all devices can connect to the wifi but not to the internet. I change the IP submask of the br-lan from>

Thanks in advance!

i this also not provider dependant? i used to use DDWRT (2013 build) to repeat the BTWi-fi signal indoors (was very new to all this at the time so didn't know the differences really) and this appears to have been running in bridge mode (as every device connected still had to sign in individually on the private network side) Whereas now with OpenWrt, having it connected in client mode allows everything to be signed in simultaneously as the public wifi only ever sees the Router, Also on my last 3 Samsung Phones, They Support "Wi-Fi Sharing" with the wireless hotspot, basically repeater mode, When you enable this a message pops up saying "Some Wi-Fi networks may not be available while Wi-Fi sharing is on" (Seems To Work For BTWi-fi) so is this a result of the same mechanism? would give easy way to test, And also Wondering How/Why they are able to block this kind of repeating? Just feeding my curiosity :slight_smile:

The typical wifi based ISP will only assign a single IP per customer and not accept you to bridge your whole private subnet/ device zoo on their public network (routing with NAT required), repeating your own private wlan is another topic.

From a technical point of view, STA connections (wifi uplink) can't be bridged at all, but need to be routed or use hacks like relayd for repeating.

Okay so this means the pi created a network with internet access and one without. My PC entered the one without. And the pi itself also didn't have internet access according to the diagnosis tool. The network I have the pi connected to seems to be the internet because I found that at one place there is "WAN" written. So probably something with the configuration failed.
I solved the problem for now by repairing the original router but I will keep learning and testing the openwrt option so I hopefully can type a solution to the problem at some time.
For now thank you all very much for your help! It's very nice how many people help in this forum!

1 Like