Only 100Mb/s for ethernet ports on NanoPi R4S?

Hi there:

My newly bought nanopi-r4s is running the latest stable openwrt, and everything works out of box, except the ethernet ports speed that confuses me a bit.

I found the two ethernet ports support only 100Mb/s under openwrt, even if both of them are Gigabit Ethernet in theory, according to the wiki .

So how can I make the two ports hit the full potential to 1000Mb/s?

Tried forcing them using ethtool ?

Tried replacing the cables?

My cables are also newly bought ones that support gigabit, so I think cable might not be the culprit. I will try to force it using ethtool these days (I'm not at home now).

Gigabit ethernet requires all 4 wire pairs, while 100Mbps only uses 2 wire pairs, so in case of a bad contact of one wire ethernet often gracefullybfalls back to 100 Mbps....

Anecdote time: some years ago I was on a similar chase and the solution was that I accidentally had used a CAT5 patch cabke with only 2 wire pairs... (not knowing such beasts would exist I thought I had done my due dilligence when confirming CAT5...) no amount of ethtool magic on either side of the link was showing any effect...

Category is usually printed on the cables...

Yes, but I initially had stopped reading after CAT5, ignoring the "2 wire pairs" part of the printed label... clearly my own responsibility/fault :wink:

My cables support 10Gbps, that's more than enough😄

the seller claims...

1 Like

I had bad contacts from bent contact springs in 8P8C sockets, resulting in the same phenotype as discussed here, a nominal 1 Gbps link fell back to 100 Mbps...

Fixed. The culprit is my switch. I connect it to the nano-pi's LAN port, and all the ports on this switch are 100Mb/s only. I will replace this switch with a better one.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.