Onhub TP-LINK TGR1900 future support?

Another auto-reboot (just now):

I have a TP-Link OnHub TGR1900, and I would gladly try out this firmware.
Where do I start, and do I need any extra hardware to get the firmware on it (like a yoshi cable or 1.8v UART)?

Just follow the instruction on the wiki page. No cables needed, just need to access the developer switch under a screw under the bottom rubber. Test images are on the wiki page as well.

Sorry @phantastar, I guess I got the instructions wrong. Kernel panics would be be captured by:

cat /sys/fs/pstore/dmesg-ramoops-*

The logs you provided don't show much useful.

Hi, thanks again for creating the firmware for Google on Hub.
I am following the these steps from the wiki to flash my asus on hub.

  1. Peel off the rubber feet at the bottom of the device to reveal the hidden switch screw
  2. Use 1.5mm hex screwdriver to remove the switch screw to reveal the developer mode button
  3. Hold the Reset button (Near the power jack)
  4. Connect power to the device
  5. The LED will be white and after a few seconds should blink orange; After a few more seconds, the LED should blink red; you may now release the Reset button
  6. Press the developer mode button at the bottom of the device. The LEDs should start blinking purple and restart
  7. Plug in USB stick containing OpenWrt
  8. Wait a few seconds for the device to finish booting.=
  9. It will start blinking purple again and beep twice. Press the developer mode button
  10. LED should turn off and device should boot your USB image
  11. Wait a few minutes for it to boot. You will know it is successfully booted when LED ring shows multiple colors.
  12. Another way to check is to connect a cable to the LAN port and continuously ping
  13. To program your image to the main flash, connect ethernet to the LAN port and run the following SSH commands:

I am currently stuck on step 11. I put my flash drive and have onhub blinking with changing color.
However, when I plugged the network cable, there is no activity and I am unable to ping.

If I restarted the device now, I hear the two beep before getting to the state of multi color blink.

Any clue on how to proceed from here?

Thanks again.

is the device you're pinging from using correct network settings? the device OnHub connected to should use DHCP or statically be in

The nic light on my laptop is not ON when I plugged the lan cable to the lan port on the onhub.

and what's the output of network details from your laptop?

If it all goes well, the led should not blink and be multi-colors (red-blue-green). I think the issue is the USB stick. Did you flash the openwrt image with balena etcher? This was mentioned above and what I used. I don't think you can just copy the .img file to the USB.

Hmm the LED does not blink red blue green, it orange with some other color similar to orange.

Yes I was using balena etcher to flash the image to usb stick (sandisk cruzer)
I am using the following file
openwrt-ipq806x-chromium-asus_onhub-squashfs-factory.bin to flash

Ok. Missed the ASUS part. I have the TP-Link flavor. The LEDs might be different. Do you have a different USB to try? The TP-Link will blink orange / reddish when the process doesn't work whether it's the openwrt image or the google recovery. Will it still boot normally if you let it?

I have tried 3 different usb just now with the same result

Below are what happens when i power on

  • Blue on for a few seconds
  • blink purple for a few seconds and then 2 beep and still purple
  • off for a few seconds
  • Blue then turning to orange/reddish (not blinking but changing)

Should i flash the bin file or the recover image to the flash drive?

I would do the recovery image and get it to boot normal then try the openwrt img again. I had issues trying different builds that I made and always had to go back to stock when it didn't work to then flash a good openwrt image.

1 Like

ok i flashed the recovery image and able to ping the router at
what should i try next?

I would try the openwrt install process again.

I finally managed to flash openwrt on the onhub.

Not sure which one solves the issues but i did the following

  1. Put the on hub into a developer mode using keyboard (ctrl-D)
  2. Reflash the image into usb disk using balena etcher
  3. After the beep, press the developer mode button

thanks again.

Btw how to verify the multi core is working or not?

Pass this command via ssh,

cat /sys/devices/system/cpu/cpufreq/policy*/scaling_governor

if you have both cores working you should see


if only once then only one core is active.

I only see one ondemand. I believe I am using an image prior to bnorris fix.

What should i do if i want to update the openwrt image now?

should i repeat the following steps with the new bin file?

## Copy firmware (-O uses the legacy SCP protocol instead of SFTP)
scp -O openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin root@
## Write firmware to eMMC and clobber secondary GPT at end of eMMC
ssh root@ -C "dd if=/dev/zero bs=512 seek=7552991 of=/dev/mmcblk0 count=33 && \
dd if=/root/openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin of=/dev/mmcblk0"

Once openwrt is running on the ASUS you can just use a sysupgrade if you have one. I made some images above that I tested on my TP-Link which has both cores working. Should work on the ASUS. If not, you'd have to go through the recovery and re-install process.

As for building a new initial factory flash image, I'm not sure how to do that.


Unfortunately I was not able to find the file.

root@OpenWrt:/sys/fs# ll
drwxr-xr-x    7 root     root             0 Jan  1  1970 ./
dr-xr-xr-x   11 root     root             0 Jan  1  1970 ../
drwx-----T    2 root     root             0 Jan 17 19:40 bpf/
dr-xr-xr-x    3 root     root             0 Jan  1  1970 cgroup/
drwxr-xr-x    3 root     root             0 Jan 18 10:01 ext4/
drwxr-xr-x    4 root     root             0 Jan 18 10:01 f2fs/
drwxr-xr-x    3 root     root             0 Jan 18 10:01 fuse/
root@OpenWrt:/sys/fs# find / -type d -name "pstore"
root@OpenWrt:/sys/fs# find / -name "dmesg*"

Please let me know if I have got it wrong. Thank you so much for your hard work.

Regards RW