Onhub TP-LINK TGR1900 future support?

Thanks for some advices. I'm already did it.
For testing purpose last time I used LAN port, to connect to main router. Then I deleted all the interfaces, and left one with static settings and device: br-lan (lan+wlan).

Then I ping some sites with bultin tool, router had connection to the internet. But when I tried to connect to wifi, right after my client recieved IP router reboots.

If someone have time and this device please test in same situation.

disabled firewall while in dumb ap mode will cause panic
as a workaround, disable ecm init script and execute sysctl -w dev.nss.general.redirect=1 to avoid error when wifi clients connected
but without ecm wifi performance is slower

1 Like

I followed my own instructions on my onhub and got the same issue of a reboot when the wifi client connected. Once I re-enabled the firewall all is good. I'm pretty sure when I've made APs before I always disabled the AP's firewall without issue. Maybe something new in 5.15 as my other APs were all on 5.10. Probably Firewall4, now that I think about it. All my APs were using Firewall3. I also made sure to remove all NSS or SQM settings as the main router is doing all that work.

1 Like

So I shouldn't disable it completely, but can allow all the things?

Thanks for answers! Didn't touch firewall at all, deleted all others than LAN interfaces, and moved "untagged" mark of WAN port to VLAN 1. And all works!

1 Like

If you can, leave WAN alone - makes your setup much simpler and you only lose one port.

If you can't, don't bridge, just remove the WAN port from VLAN2 and add it to VLAN1 (they're all sitting on the same switch anyways) - once done, VLAN2 and WAN/ WAN6 can be removed as well.

Again, if you can, go with option 1.

1 Like

Interesting. I've disabled firewall and dnsmasq on both my TPLink switches. Also configured fast roaming. Using your NSS build to get around 450mbps (out of a possible 500 from ISP). Everything just works and very stable.
Next things to play with are Bluetooth and the LEDs. Oh, and if I can silence the BEEP on reboot, that'd be nice too. :slight_smile: hehe.. when I get around to it. :stuck_out_tongue:
Thanks again, mate!

1 Like

You're welcome. I haven't been able to get the Bluetooth working yet but it's not a huge issue for me. Would just be fun since it supports it. I have played music streams through it with mpg123, though. The LEDs are fun to play with since it has 6 with 3 colors each. Did you see this? I haven't tried it yet.

1 Like

Your patch applies nicely and compiles well! I made a test build for ASUS or TP Link devices. Anyone is free to try it and give feedback.


Looks good, performance-wise... but is it me or is the System/Software menu now missing?! :wink:
Also, I'm partial to the Bootstrap.Dark interface over OpenWRT2020... but I'm just nitpicking now. :slight_smile: Great work, sir! Keep it up!

When I ran this command it ask for a password

scp -O openwrt-ipq806x-chromium-tplink_onhub-squashfs-factory.bin root@

root@'s password:

I reset to factory setting and booted with OpenWrt image and was able to ping the router.
What could be the root password? I try it a few time and get the same result

Huh, that's weird. Default root password for these images is usually blank <>.
Have you tried just hitting Enter at that passwd prompt?

Otherwise, you may have flashed but chosen to keep previous settings? In which case, your previous root passwd (whatever that was) would be preserved.

Which image are you using on the USB stick? Do you have the luci GUI? If so, I would try to reset it from the backup/flash firmware page and do the perform reset and see if you can get in after that, before trying to transfer the file.

That's cool! I'm playing with it now... I found the animated patterns annoying so I quickly made some static patterns (including some country flags) and then saved them to the LUCI Custom Commands dashboard. I can chg the mood lighting at the touch of a button now. :slight_smile:

Here's Italy :it:

setled="ash /root/led_write.sh"

$setled 0 00ff00
$setled 1 ffffff
$setled 2 ff0000
$setled 5 ff0000
$setled 4 ffffff
$setled 3 00ff00

What an awesome thread! Thanks to all the contributors to this project - (sorry if I missed anyone) of particular note bnorris, regae, stonics, @dadogroove, @ACwifidude, ryjelsum, konus, Trigger31337. I'm new to the world of OpenWrt, so I'll be starting from scratch. I have 3 TP-LINK OnHubs - I'm looking to use them in mesh - all hard wired. I see some updated files/guides have been provided by stonics here, @dadogroove here, and @ACwifidude here, but wondering which are the appropriate files to use. What's different about the ath10k files?

openwrt-ipq806x-chromium-tplink_onhub-initramfs-fit-zImage.itb.vboot (**not sure how to use this**)



Based on what I've read I need to do the following :
-Reference Guide
-create USB with flashed with xyz-factory.bin using Balena Etcher
-follow steps to get Onhub into developer mode (LEDS blink purple and restart)
-Plug in prepared USB drive and wait for device to turn purple and beep x 2 times
-Press developer button again
-Device should boot from USB after a few minutes and show Rainbow LED
-Or connect to LAN and ping
-Step 13 from workstation - SCP to transfer xyz-factory.bin to device
-Step 13 from workstation - SSH into device to write image to device memory eMMC
-Through SSH install LuCI web interface using opkg commands
-After writing to eMMC, be sure to reboot from SSH

These are the items I'm not entirely clear on :
-How do you configure MESH - as I see other posts about running as AP?
-How do I install the xyz-sysupgrade.bin (through LuCI or SCP/SSH) and write it to device memory?
-Can you keep upgrading over top existing setup with updated xyz-sysupgrade.bin as new updates become available?
-Expand storage (should I do this and why?)
-Do I need to do any NSS updates with these aforementioned files?
-Bluetooth speaker support - are they in these files?

Thanks for your input

you wan to install luci after booting from eMMC

Mesh = up-link via radio but you also say all hard wired ?
if your up-link is hard wired you want router & 2 x dumb Access points