One of the DDNS Services never starts at boot

Hello,
I run 4 DDNS Services on OpenWRT and one of them never starts at boot.
The non working Service looks like this

config service 'home_v6'
	option service_name 'cloudflare.com-v4'
	option use_ipv6 '1'
	option enabled '1'
	option lookup_host 'domain'
	option username 'Bearer'
	option password 'XXX'
	option use_https '1'
	option cacert '/etc/ssl/certs'
	option ip_source 'interface'
	option interface 'lo'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option domain 'home@domain'
	option ip_interface 'lo'

A Other one which also points at cloudflare looks like this and works

config service 'home_v4'
	option service_name 'cloudflare.com-v4'
	option use_ipv6 '0'
	option enabled '1'
	option lookup_host 'home.domain'
	option username 'Bearer'
	option password 'XXX'
	option use_https '1'
	option cacert '/etc/ssl/certs'
	option ip_source 'network'
	option ip_network 'wan'
	option interface 'wan'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option domain 'home@domain'

IPv6 to a other DNS provider works also

config service 'docsis_v6'
	option use_ipv6 '1'
	option enabled '1'
	option lookup_host 'domain'
	option domain 'domain.ipv64.de'
	option username '.'
	option password 'XXX'
	option use_https '1'
	option cacert '/etc/ssl/certs/ca-certificates.crt'
	option ip_source 'network'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'
	option interface 'wan6'
	option update_url 'https://ipv64.net/update.php?key=[PASSWORD]&host=[DOMAIN]'
	option ip_network 'wan6'

The only difference I see is that the non working one points to interface lo but I don't see why that should cause the problem.
Does somebody have a idea?

Thanks for help

do you have an interface called lo ?

1 Like

yes I do have

And what is the IP address of interface lo?
Usually it is 127.0.0.1/8 and that is not a valid ip address for remote access

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          inet6 addr: 2a02:8070:XXXX:XXXX::/64 Scope:Global
          inet6 addr: fd00:XXX:XXX::/64 Scope:Global
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:42944 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42944 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4724789 (4.5 MiB)  TX bytes:4724789 (4.5 MiB)

The IPv6 one is public

I do not use cloudfare but maybe the v4 points to IPv4?

that is version 4 of the plugin and does not correlate with the IP version.

  • Can you explain why and how your lo interface got a Public IPv6 address assigned - did your ISP provide a static IPv6 /64 subnet for your use? (if no, this could be the issue)
  • I noticed that the subnet belongs to Vodafone and not CloudFlare
  • Did some DDNS instructions tell you to do this?
  • Is there a reason you don't assign this IP to wan or some other normal Ethernet-based interface?

FYI:

  • lo is not valid on the DDNS web GUI
  • Since lo is always up - not sure there would be a hotplug associated for starting DDNS
  • (for that same reason) lo is usually invalid for such a config
2 Likes

So I'm able to use IPv6 hints and custom suffix to form the IPv6 address to my liking. I have a dynamic /59 subnet for my use.

It would be very strange if those IPs would belong to CloudFlare since cloudflare is the DNS Provider and not my ISP.

no

as written above

That is new because I did setup the DDNS Service via GUI years ago.

Since the service runs in a defined interval and not based on events that doesn't matter.

You know a different way to generate a custom IPv6 address which gets automatically updated on a prefix change?

It wasn't clear if these IPs were from a WARP tunnel - thank you for clarifying.

Can we see your network config?

I can't find anything that explains why you're assigning Public IPs to lo. My apologies.

It's unclear what you mean by this. If loopback never goes up or down, how can you have an event that uses is

  • What do you mean by the phrase "a custom IPv6 address which gets automatically updated on a prefix change"?
  • It may help if you explain why you don't assign this IP to wan or a new normal Ethernet-based interface

This is what DDNS generally does, so it's not clear what you mean in particular.

Which part is new, are you saying lo was listed in the past?

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth12'

config interface 'wan6'
	option proto 'dhcpv6'
	option iface_dslite '0'
	option device '@wan'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'nginx_LB'
	option proto 'static'
	option ipaddr '10.10.10.10'
	option netmask '255.255.255.255'
	option defaultroute '0'
	option delegate '0'
	option ip6ifaceid '::1337'
	option ip6assign '64'
	option device 'lo'
	list ip6class 'wan6'
	list ip6class 'wanb6'
	list ip6class 'local'
	option ip6hint '420'
[...]

Because afaik there is no way you simply can a assign a static IP on the wan Interface if you have a dynamic prefix. If that would be possible I would do that but the way I do it is the only working way I have found. If you know how to do it I will try your way.

If the service runs every 5 minutes no matter what for what do I need any event?

I want the IP 2a02:8070:XXXX:420::1337 for example. I'm in controll of the suffix but the prefix I get dynamicly from my ISP, so I can't simply set my wan6 interface to static

because as far as i can tell that is not possible. Please provide me a way how to do that and I will try.

Not sure what you mean.

Yes it was.

1 Like

Where is this lo config you noted?

?

But you don't have a static IP.

  • Create a new interface
  • Assign the IP there via your config

If your problem is that you want to set a DDNS address which is not your WAN but another address in your LAN, then there are IPv6 services which just use your prefix and the suffix you set.

I think, but am not sure, it is dynv6

1 Like

As egc inquired - are you trying to set this IP/DDNS for use on a downstream server, or for a service running on the OpenWrt itself?

because I get a /59 and not a /56 or /48 my IPs are not predictable in a way that this would work sadly.

This is for a service running on OpenWRT itself.

1 Like

I'm not sure why you placed lo this into your 'nginx_LB' config, but that's invalid. You shouldn't list the same PHY on multiple logical interface configs.

1 Like

What makes you think that?

Because:

  • This PHY is already listed under the interface 'loopback'
  • This can cause another undocumented anomaly - where the interface could exist in multiple firewall zones with different security settings

then how do I achieve the same with a valid config?

My suggestion would be to do the following:

Is there a reason or issue you're unable to create an interface, or assign this to IP to an existing interface (not loopback)?

1 Like