One device suddenly can't connect to 2.4gHz, while it can to 5gHz

I'm trying to debug an issue that i'm having where my android phone "suddenly" can't connect to the 2.4gHz wifi of my router.

steps to reproduce:
-enable wifi on phone
-find correct SSID
-fill in password
now the phone shows 'connecting...' followed by 'saved', and attempts to connect a number of times, then says 'disabled' for this specific wifi network.

I've enabled debugging logs for hostapd through the CLI, as well as for 'system' through LuCI, but I don't see the device in there at all.

As far as I am aware nothing has changed on my router, nor on my phone. I have tried the following:

-reset the network settings on my phone (no effect)
-connect other device to 2.4gHz of router (this works fine)
-connect phone to other 2.4gHz networks (this works fine)
-set a static IP on my phone (no effect)

phone = Nokia 8 sirocco, running android 9
router = WRT1900AC(v1), running OpenWrt 18.06.4 r7808-ef686b7292

tl;dr: how can I get useful logs out of my router to determine why my phone will not connect to the 2.4gHz wifi?

Could you post the uci show wireless for a start?
Use preformatted text </>

logread would be a good starting point

2 Likes

Hi Trendy,

root@CH23:/# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.path='soc/soc:pcie@82000000/pci0000:00/0000:00:02.0/0000:02:00.0'
wireless.radio0.hwmode='11g'
wireless.radio0.country='00'
wireless.radio0.txpower='20'
wireless.radio0.htmode='HT20'
wireless.radio0.legacy_rates='0'
wireless.radio0.channel='5'
wireless.radio0.log_level='1'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='2.4GHZ_SSID'
wireless.default_radio0.encryption='psk2'
wireless.default_radio0.key='**************'
wireless.default_radio0.macaddr='XX:XX:XX:XX:XX:XX'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.channel='36'
wireless.radio1.hwmode='11a'
wireless.radio1.path='soc/soc:pcie@82000000/pci0000:00/0000:00:03.0/0000:03:00.0'
wireless.radio1.htmode='VHT80'
wireless.radio1.country='00'
wireless.radio1.txpower='20'
wireless.radio1.legacy_rates='0'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='5GHZ_SSID'
wireless.default_radio1.encryption='psk2'
wireless.default_radio1.key='**************'
wireless.default_radio1.macaddr='YY:YY:YY:YY:YY:YY'

I forgot to mention that I used logread, but that's one of the logs i meant with:

I don't see anything very wrong here.
If these are the real SSIDs I would try to change into something without special characters. Same for passwords.
Also countrycode 00 might cause some unexpected behavior.
Does the 5GHz work or the phone is not capable?

I have changed the config to use the NL countrycode, changed the SSID to have only letters and numbers, and the same for the password. still the same.

It did, and still does connect to the 5GHz band no problem. this too has countrycode 00, and a difficult password.

@CH23, did you ever find a solution? I'm seeing the same problem with a Moto G5 Plus (Android 8.1.0) not connecting to 2.4GHz (only connecting on 5GHz) on a WRT1200ac with the latest davidc502 build. Other 2.4GHz routers can be connected to.
I'm not looking for any help to troubleshoot the davidc502 build, just wondering if this might be some more general OpenWRT setting that causes it.

Having the same issue both Moto G6's, I have connection to 5ghz only and then they will not cast to anything on the 2.4ghz wireless. Where my tablet is connecting to 2.4ghz and can cast to any Chromecast on either wi-fi network.

I have the G6's connecting to 2.4Ghz now but I'm not sure why this fixes it. In wi-fi settings for the 2.4ghz network under the advanced tab you need you tick the "Allow legacy 802.11b rates". They don't use 802.11b rates but without it no connection, with it they connect straight away, just no idea why this is needed...

Still have the Chromecast issues, as it is as if the bridge between 5, 2.4ghz and LAN is not working as if the phone is on 5ghz and the Chromecast is it works, if the Chromecast is on 2.4ghz it does not

Re the Chromecast issues and to help anyone else. I had the STP (spanning tree protocol) turned on in the advanced settings of the LAN bridge, turning this "off" fixed the Chromecast issues and I can now see all Chromecasts on either wi-fi band.