One 100mbps device caps all uploads 100mpbs

I have a Linksys WRT3200ACM router, running 22.03.0, with a 600 mbps (symmetric) internet connection.

I can download and upload at full speed from my wired PC; however, when I plug a 100 mbps device to the router, wired downloads remain at 600 mbps, but uploads do not go faster than 100 mbps. Wireless traffic remains unaffected, and I can upload and download using a phone at full speed.

ethtool does not show anything weird, all ports on the switch are full-duplex at 1000 mpbs (except the port where the 100 mbps device is plugged, obviously).

EDIT: This does not happen with the router provided by the ISP.

Mmmh, pause frames? This would be a switch issue....
rant on: personally, I dislike router designs that implement the wan port via a switch....

There is another thread where this same type of behavior was noted...

Seems like there is something wrong with the internal switch configuration... have you tried 23.05.0-RC2? Or something earlier (like 21.02 or even pre-DSA 19.07)? Might be helpful to understand what version(s) are affected.

Yup, I ended up just buying a switch an plugging all 100BASE devices to it, and plugging the switch to the main router (x86 openwrt). I have nothing using the R8000 lan ports at this point except to connect it to the main router.

1 Like

Yes, this is it!

After investigating a bit about pause frames / flow control, I tried disabling on the port connected to the offending device:

ethtool -A lan4 autoneg on rx off tx off

And it works... many thanks!!!


Yes I will have to do this, this device as issues with the switch. Unfortunately, this is the main router at home, and any serious tinkering has to wait until the weekend.

Although your issue was resolved. Have you checked this and this? May help to better understand the issue?

I browsed both links, thanks for pointing me there. Looks like this is a common issue, and the only solutions are to disable flow control (as @moeller0 suggested) or use an intermediary switch (as @carofe commented).

1 Like

mt7621 issue

Qca8k have a similar problem are we missing an RFC that makes flow contro not compatible with 100mbps?

Considering also mvebu suffer from this and we are at 3 devices I wonder if it's a good idea to introduce some kind of errata and disable flow control on 100mbps?

@robimarko ideas?


What is the exact switch model being used, I can check if an errata is published?

qca8k with flow control scenario with 1000mbps and 100mbps device connected, 1000mbps gets downgraded to 100mbps by checking with an iperf

Hm, this would be interesting thing to test against multiple switches as this may just be a limitation of flow control in general

Yes it's too strange to see this limitations in lots of switch... If I'm not wrong qca8k also have a special bit for flow control in 100mbps but never checked it...

In my case, the flow control is off between the wifi AP and the 100BASE device, and on between the wifi AP and the main router, and there were pause frames in between the wifi AP and the main router when the 100BASE device was connected to the wifi AP. I have more details in the thread posted at #3

If IP4/6 QoS (Layer3) (and/or multiple VLANs) is used, then it is imperative to turn off flowcontrol (L2), otherwise the flow will be affected.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.