Once DSA support has been added to ipq806x, is there an easy way to migrate via edits to /etc/config/network

I am sure that eventually DSA support for ipq806x will get merged. I have a netgear R7800 at my parent's house remotely located. Is there an easy way to convert the existing switch config configuration and reboot the device and have it Just Work™?

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd74:9589:935a::/48'
	option packet_steering '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option description 'lan'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5'
	option vid '2'
	option description 'wan'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option description 'iot'
	option ports '6t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option description 'guest'
	option ports '6t'

config interface 'lxc'
	option device 'lxcbr0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.4.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'IOT'
	option device 'br-iot'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config interface 'guest'
	option device 'br-guest'
	option proto 'static'
	option ipaddr '192.168.4.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

config device
	option type 'bridge'
	option name 'br-lan'
	list ports 'eth1.1'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-iot'
	list ports 'eth1.3'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth1.4'
	option ipv6 '0'

config device
	option type 'bridge'
	option name 'lxcbr0'
	option ipv6 '0'
	option bridge_empty '1'

config device
	option name 'eth1.1'
	option type '8021q'
	option ifname 'eth1'
	option vid '1'
	option ipv6 '0'

config device
	option name 'eth1.3'
	option type '8021q'
	option ifname 'eth1'
	option vid '3'
	option ipv6 '0'

config device
	option name 'eth1.4'
	option type '8021q'
	option ifname 'eth1'
	option vid '4'
	option ipv6 '0'

The short answer is "no".

You'd need to be rather familiar with DSA and this device (e.g. having tested the configuration on an identical device before) to even try - and that's risky as well. swconfig --> dsa is a rather fundamental change, with (indirect) consequences for other (configuration-) files and -choices as well, resetting to defaults and building up again from there is strongly recommended.

My suggestion would be to plan ahead in advance, look at it long term. 23.05.x will remain at swconfig, that buys you a good two years (~support cycle) to come up with a strategy. Either switch them to a master snapshot after DSA has been merged during your next visit or use your local mail service (as in, mail them a preconfigured device and let them send the r7800 back to you, so you can do the migration at your place). A cheap/ old device would probably already do as this kind of cold spare (with reduced, but usable features/ performance). If you feel lucky, you might even use that to save yourself the second turn around of mailing the r7800 back and forth, by using the cold spare as temporary VPN bridge head to reset/ reconfigure the r7800 remotely. All your parents would have to do, is replacing the devices 1:1, with good labelling of ports and cables and while having them on the (cell-) phone that should be possible.

2 Likes

Thanks for the reply. I will keep an eye on the PR for merge status. The device is running a snapshot from master currently. Probably best to have physical access to make the change.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.