On Linksys EA6350 v4 its revert everytime to original firmware

Hi, on Linksys EA6350 V4 i did this:
0. Connected the rooter with a lan cabel

  1. Use the Linksys GUI to flash the Linksys OEM firmware.
  2. Flash OpenWrt squashfs-factory with this file:
  3. The rooter booted in openwrt

Then i tryed to enter in the web gui with th ip which wsnt worked.

Does the gui working only after upgrade to (openwrt-ramips-mt7621-linksys_ea6350-v4-squashfs-sysupgrade.bin) ?

then i didnt added the counter reset in: etc/rc.local

/rom/sbin/mtd unlock s_env
/rom/sbin/mtd erase s_env
exit 0

and soon after i rebooted it fiew times it turned back to the linksys stock firmware.

After i tryed to flash again openwrt but after the restart it turn back dayrecht to linksys firmware.

I tried to flash fiew times the linksys firmware to replace both partitions with the originall and then to flash again openwrth but the result is the same.

Its looking that the counter isnt zeroing after the new flash and it try to boot from the partittion unsucsesfuly and then turn to other partition.

Sorry i for the lame explanation.

Can someon help me to understand what happend and how i can flash openwrth sucsesfuly.


That is a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

The wiki for your device mentions

Warning: If both partitions are overwritten with non-Linksys firmwares, there is no safe method of reverting back to Linksys OEM firmware at time of writing.

So please be aware of this before replacing both partitions.

Thanks for the fast answare.
I realised that i have to install Luci but now i cannot boot anymore from the paartition where i flashed openwrt its boot only in the original firmware.
I will check the links that you send me, but how to reach working openwrt partition?

update: the seccond link i used for the procedure but there no information about "LuCI"

The first link prompt me to use image with preinstald "LuCI" or i can install it from the command line.

if i reach the moment to boot from the openwrt partition i can do it with SSH but how to swich to the other partition?

Can you point me which image contain "LuCI" for my model?

thank you again

Edit: sorry ignore. Someone else with more knowledge on how to set the boot partition will chime in soon.

Hi The problem is that now i cannot anymor turn to the other partititon. I Flashed again openwrt from the stock firmware but after the restart it turn dayrect to the original firmware. I cannot anymore to reach working openwrth partition.

I hope you understand

Have you tried the power method as mentioned in this Linksys article? This should let you switch to the alternative partition with openwrt on it.

Yes i just tryed. But i will check again.
I think its not working cos' i already booted three times from the working openwrt partition and i didnt seted the zeroing of the counter. So now even if i swich to the other partition there is no valid lynksys boot to zeroe the counter and it turn me back dayrect to the original partition.

I tought if i flash the original partition again to replace the openwrth partition and boot to zeroe the counter, but it doesnt work. I even instald 4 time in a row the originall firmware but the same result.
i dont know how to fix this?!

Same experience than on a EA7300v2.

You need to install OpenWrt on partition A, and add the code in /etc/rc.local. That will erase the bootcounter at each boot. To do so, you must start from Linksys OEM on partition B, and than flash OpenWrt (on A).

So flash Openwrt, from whatever partition Linksys is. If you are running OpenWrt after reboot, than it is on A. Just add thecode.
If you are still booting Linksys, than you are running Linksys on A. Flash Linksys over itself, you will now boot from B. Flash OpenWrt, it will be on A. Add the code.

Be patient, it works.

1 Like

Hi verry usful information,
i could get to connection with ssh to the working openwrt partition.
then i run this command:

opkg update

but this for installing LuCi doesnt work

opkg install luci

its give tihs error

*root@OpenWrt:~# opkg install luci
Unknown package 'luci'.

how to install luci?

and after how to edit /etc/rc.local with:

/rom/sbin/mtd unlock s_env
/rom/sbin/mtd erase s_env
exit 0

sorry for lame questions
and 10x in advance

Is your router connected to the internet? What happens if you type the following into a SSH session


To add the lines to rc.local you can run the following

echo "/rom/sbin/mtd unlock s_env
/rom/sbin/mtd erase s_env
exit 0" > /etc/rc.local

Thanks your posts ar verry helpfull.

My rooter is NOT connected to the internet. I connected it troug the other rooter. But it doesent recieve it.
i seted IP dns .. cabel connection, using this info:


I dont know what im doing wrong.

Now how i understand i have two tasks. To install LuCi online or ofline and to set the counter.

Connect an ethernet cable from your existing network to the wan port on the EA6350 V4. This should give you internet access.

Then try to ping on the EA6350 V4.

I wanna thank you for your help.
After the upgrade of openwrt the gui startrted.
Just one more question.
please tel me about this command:

echo "/rom/sbin/mtd unlock s_env
/rom/sbin/mtd erase s_env
exit 0" > /etc/rc.local

And what is the program for text edyting in openwrth like "nano" if i need to set or edit some more config?
can i just copy and paste it using ssh connection. I ask cos` i see that is one command but on three lines.

1 Like

The command overwrites the /etc/rc.local file with the data in the quotes. I assumed as you have a fresh install, you won't have anything you want to keep in there!

Now you have Luci, you can also goto

System > startup > local startup

This will achieve the same thing.

To edit text files from the shell you can use vi. If you prefer nano then you can install that using opkg.

1 Like

It took me some time to understand myself :slight_smile:
To be sure that the bootcounter tweak works, perform several reboot (let's say 4). If you boot OpenWrt at the end than everything works. There is a PR submitted to patch this problem, but it hasn't been validated yet.

Why do you need to install Luci ? Are you using a snapshot ? Just use the stable 22.03.3 that already includes Luci. Apparently you have no WAN connection.

1 Like

i needed LuCi cos i flashed a snapshot but after the upgrade everything is ok.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.